aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorQuentin Dufour <quentin@deuxfleurs.fr>2021-10-25 17:19:24 +0200
committerQuentin Dufour <quentin@deuxfleurs.fr>2021-10-29 11:34:01 +0200
commitcc1caa87fbbc11338a650623c7776bf57402cd16 (patch)
tree878cd6695e3a1c5a262a7fdeeaeef32c54c43f55 /shell.nix
parent69b89fb46df3b2b0ab189218812efdcf5852f8f2 (diff)
downloadgarage-cc1caa87fbbc11338a650623c7776bf57402cd16.tar.gz
garage-cc1caa87fbbc11338a650623c7776bf57402cd16.zip
Use Rust binaries from Nix instead of rustup
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix14
1 files changed, 9 insertions, 5 deletions
diff --git a/shell.nix b/shell.nix
index f407ed95..a91a9e20 100644
--- a/shell.nix
+++ b/shell.nix
@@ -1,6 +1,5 @@
{
system ? builtins.currentSystem,
- crossSystem ? null,
rust ? true,
integration ? true,
release ? true,
@@ -10,10 +9,9 @@ with import ./nix/common.nix;
let
pkgs = import pkgsSrc {
- inherit system crossSystem;
- overlays = [ cargo2nixOverlay rustOverlay ];
+ inherit system;
+ overlays = [ cargo2nixOverlay ];
};
- rustDist = pkgs.buildPackages.rust-bin.stable.latest.default;
kaniko = (import ./nix/kaniko.nix) pkgs;
in
@@ -60,7 +58,13 @@ function refresh_index {
'';
nativeBuildInputs =
- (if rust then [ rustDist (pkgs.callPackage cargo2nix {}).package ] else [])
+ (if rust then [
+ pkgs.rustPlatform.rust.rustc
+ pkgs.rustPlatform.rust.cargo
+ pkgs.clippy
+ pkgs.rustfmt
+ /*(pkgs.callPackage cargo2nix {}).package*/
+ ] else [])
++
(if integration then [ pkgs.s3cmd pkgs.awscli2 pkgs.minio-client pkgs.rclone pkgs.socat pkgs.psmisc pkgs.which ] else [])
++