aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorAlex <lx@deuxfleurs.fr>2025-02-03 15:54:54 +0000
committerAlex <lx@deuxfleurs.fr>2025-02-03 15:54:54 +0000
commitb9df2d1ad1e80745350e25fd44ddaa0f0c6bcbab (patch)
tree02ca809d1305f8f76eedfac145fb843489d65d35 /shell.nix
parent4dc2bc337f10be616a141ba8b52564038ef3ae41 (diff)
parent390a5d97fece744bcad3c5b7b7d31b2722d0b092 (diff)
downloadgarage-b9df2d1ad1e80745350e25fd44ddaa0f0c6bcbab.tar.gz
garage-b9df2d1ad1e80745350e25fd44ddaa0f0c6bcbab.zip
Merge pull request 'compile with crane' (#950) from nix-crane into main
Reviewed-on: https://git.deuxfleurs.fr/Deuxfleurs/garage/pulls/950
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/shell.nix b/shell.nix
index cc06f0fb..cfccfe94 100644
--- a/shell.nix
+++ b/shell.nix
@@ -3,7 +3,7 @@
with import ./nix/common.nix;
let
- pkgs = import pkgsSrc {
+ pkgs = import nixpkgs {
inherit system;
};
winscp = (import ./nix/winscp.nix) pkgs;
@@ -39,7 +39,7 @@ in
--endpoint-url https://garage.deuxfleurs.fr \
--region garage \
s3 cp \
- ./result-bin/bin/garage \
+ ./result/bin/garage \
s3://garagehq.deuxfleurs.fr/_releases/''${CI_COMMIT_TAG:-$CI_COMMIT_SHA}/''${TARGET}/garage
}