aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorQuentin Dufour <quentin@deuxfleurs.fr>2022-02-05 19:08:10 +0100
committerQuentin Dufour <quentin@deuxfleurs.fr>2022-02-05 19:12:35 +0100
commit610c7ea6af994ac2591ef234dc3f6b33943907e0 (patch)
tree7444272e7421c8db929312bc3bcafba0911a8047 /shell.nix
parent38bb74bfd8d28bcf4eb3eea5ece5c50a34f676a9 (diff)
downloadgarage-610c7ea6af994ac2591ef234dc3f6b33943907e0.tar.gz
garage-610c7ea6af994ac2591ef234dc3f6b33943907e0.zip
Generate and upload a JSON resultfeature/generate-json-builds
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix12
1 files changed, 9 insertions, 3 deletions
diff --git a/shell.nix b/shell.nix
index 1d70730e..57e95e01 100644
--- a/shell.nix
+++ b/shell.nix
@@ -51,9 +51,15 @@ function refresh_index {
--endpoint-url https://garage.deuxfleurs.fr \
--region garage \
s3 cp \
- --content-type "text/html" \
- result \
- s3://garagehq.deuxfleurs.fr/_releases.html
+ result/share/_releases.json \
+ s3://garagehq.deuxfleurs.fr/
+
+ aws \
+ --endpoint-url https://garage.deuxfleurs.fr \
+ --region garage \
+ s3 cp \
+ result/share/_releases.html \
+ s3://garagehq.deuxfleurs.fr/
}
function refresh_toolchain {