aboutsummaryrefslogtreecommitdiff
path: root/nix/compile.nix
diff options
context:
space:
mode:
authorAlex Auvolat <alex@adnab.me>2022-09-06 17:20:10 +0200
committerAlex Auvolat <alex@adnab.me>2022-09-06 17:20:10 +0200
commit2c2b93acdf3db1d6c379964f557abf082df269b9 (patch)
treeb4f8a2f32073c551fd92310e6e25c19d4142c1dd /nix/compile.nix
parentbbb970965c41fbe5bdd90409dc8afdd589f24ed5 (diff)
downloadgarage-2c2b93acdf3db1d6c379964f557abf082df269b9.tar.gz
garage-2c2b93acdf3db1d6c379964f557abf082df269b9.zip
Update Nix files with optional db engines
Diffstat (limited to 'nix/compile.nix')
-rw-r--r--nix/compile.nix5
1 files changed, 2 insertions, 3 deletions
diff --git a/nix/compile.nix b/nix/compile.nix
index 450b6398..ea431a7e 100644
--- a/nix/compile.nix
+++ b/nix/compile.nix
@@ -117,7 +117,6 @@ let
It speeds up the compilation (when the feature is not required) and released crates have less dependency by default (less attack surface, disk space, etc.).
But we want to ship these additional features when we release Garage.
In the end, we chose to exclude all features from debug builds while putting (all of) them in the release builds.
- Currently, the only feature of Garage is kubernetes-discovery from the garage_rpc crate.
[5] We don't want libsodium-sys and zstd-sys to try to use pkgconfig to build against a system library.
However the features to do so get activated for some reason (due to a bug in cargo2nix?),
@@ -130,8 +129,8 @@ let
/* [2] */ hardeningDisable = [ "pie" ];
};
overrideArgs = old: {
- /* [4] */ features = [ "bundled-libs" ]
- ++ (if release then [ "kubernetes-discovery" "telemetry-otlp" "metrics" ] else []);
+ /* [4] */ features = [ "bundled-libs" "sled" ]
+ ++ (if release then [ "kubernetes-discovery" "telemetry-otlp" "metrics" "lmdb" "sqlite" ] else []);
};
})