aboutsummaryrefslogtreecommitdiff
path: root/nix/build_index.nix
diff options
context:
space:
mode:
authorQuentin Dufour <quentin@deuxfleurs.fr>2022-02-05 19:08:10 +0100
committerQuentin Dufour <quentin@deuxfleurs.fr>2022-02-05 19:12:35 +0100
commit610c7ea6af994ac2591ef234dc3f6b33943907e0 (patch)
tree7444272e7421c8db929312bc3bcafba0911a8047 /nix/build_index.nix
parent38bb74bfd8d28bcf4eb3eea5ece5c50a34f676a9 (diff)
downloadgarage-610c7ea6af994ac2591ef234dc3f6b33943907e0.tar.gz
garage-610c7ea6af994ac2591ef234dc3f6b33943907e0.zip
Generate and upload a JSON resultfeature/generate-json-builds
Diffstat (limited to 'nix/build_index.nix')
-rw-r--r--nix/build_index.nix10
1 files changed, 6 insertions, 4 deletions
diff --git a/nix/build_index.nix b/nix/build_index.nix
index a0313a9e..4625e3ae 100644
--- a/nix/build_index.nix
+++ b/nix/build_index.nix
@@ -88,10 +88,8 @@ let
builds = builtins.sort cmpDate (map (x: { version = x; builds = builtins.getAttr x builds_per_version; }) versions_commit);
}
];
-in
-{
- json = pkgs.writeTextDir "share/_releases.json" (builtins.toJSON sorted_builds);
+ json = pkgs.writeTextDir "share/_releases.json" (builtins.toJSON sorted_builds);
html = pkgs.writeTextDir "share/_releases.html" ''
<!doctype html>
<html>
@@ -146,4 +144,8 @@ in
</body>
</html>
'';
-}
+in
+ pkgs.symlinkJoin {
+ name = "releases";
+ paths = [ json html ];
+ }