aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorAlex Auvolat <alex@adnab.me>2023-04-25 14:46:47 +0200
committerAlex Auvolat <alex@adnab.me>2023-04-25 14:46:47 +0200
commit5efcdc0de3121da18e7531a9f8196ef38cecd93c (patch)
treeeeca4d33aabec4150296f6c475224a8510563204 /flake.nix
parenta16eb7e4b8344d2f58c09a249b7b1bd17d339a35 (diff)
downloadgarage-5efcdc0de3121da18e7531a9f8196ef38cecd93c.tar.gz
garage-5efcdc0de3121da18e7531a9f8196ef38cecd93c.zip
Update rust toolchain to 1.68 and simplify Nix stuffnix-update-simplify
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix20
1 files changed, 17 insertions, 3 deletions
diff --git a/flake.nix b/flake.nix
index 7eb9e33b..3ae3668d 100644
--- a/flake.nix
+++ b/flake.nix
@@ -2,16 +2,30 @@
description =
"Garage, an S3-compatible distributed object store for self-hosted deployments";
+ # Nixpkgs unstable as of 2023-04-25, has rustc v1.68
inputs.nixpkgs.url =
- "github:NixOS/nixpkgs/a3073c49bc0163fea6a121c276f526837672b555";
+ "github:NixOS/nixpkgs/94517a501434a627c5d9e72ac6e7f26174b978d3";
+
inputs.cargo2nix = {
# As of 2022-10-18: two small patches over unstable branch, one for clippy and one to fix feature detection
url = "github:Alexis211/cargo2nix/a7a61179b66054904ef6a195d8da736eaaa06c36";
+
+ # As of 2023-04-25:
+ # - my two patches were merged into unstable (one for clippy and one to "fix" feature detection)
+ # - rustc v1.66
+ # url = "github:cargo2nix/cargo2nix/8fb57a670f7993bfc24099c33eb9c5abb51f29a2";
+
+ # Rust overlay as of 2023-04-25
+ inputs.rust-overlay.url =
+ "github:oxalica/rust-overlay/74f1a64dd28faeeb85ef081f32cad2989850322c";
+
inputs.nixpkgs.follows = "nixpkgs";
};
- inputs.flake-utils.url = "github:numtide/flake-utils";
- outputs = { self, nixpkgs, cargo2nix, flake-utils }:
+ inputs.flake-utils.follows = "cargo2nix/flake-utils";
+ inputs.flake-compat.follows = "cargo2nix/flake-compat";
+
+ outputs = { self, nixpkgs, cargo2nix, flake-utils, ... }:
let
git_version = self.lastModifiedDate;
compile = import ./nix/compile.nix;