aboutsummaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
authorQuentin <quentin@dufour.io>2022-01-12 19:04:55 +0100
committerAlex <alex@adnab.me>2022-01-12 19:04:55 +0100
commitb4592a00fee3504b80aab9a8ee46bbacf7612e4a (patch)
treef4130c9e5553a475598f6101db3ca6059f042f95 /default.nix
parent9cb2e9e57ce1aab23d8c3b2aaa7581c8e8b78253 (diff)
downloadgarage-b4592a00fee3504b80aab9a8ee46bbacf7612e4a.tar.gz
garage-b4592a00fee3504b80aab9a8ee46bbacf7612e4a.zip
Implement ListMultipartUploads (#171)
Implement ListMultipartUploads, also refactor ListObjects and ListObjectsV2. It took me some times as I wanted to propose the following things: - Using an iterator instead of the loop+goto pattern. I find it easier to read and it should enable some optimizations. For example, when consuming keys of a common prefix, we do many [redundant checks](https://git.deuxfleurs.fr/Deuxfleurs/garage/src/branch/main/src/api/s3_list.rs#L125-L156) while the only thing to do is to [check if the following key is still part of the common prefix](https://git.deuxfleurs.fr/Deuxfleurs/garage/src/branch/feature/s3-multipart-compat/src/api/s3_list.rs#L476). - Try to name things (see ExtractionResult and RangeBegin enums) and to separate concerns (see ListQuery and Accumulator) - An IO closure to make unit tests possibles. - Unit tests, to track regressions and document how to interact with the code - Integration tests with `s3api`. In the future, I would like to move them in Rust with the aws rust SDK. Merging of the logic of ListMultipartUploads and ListObjects was not a goal but a consequence of the previous modifications. Some points that we might want to discuss: - ListObjectsV1, when using pagination and delimiters, has a weird behavior (it lists multiple times the same prefix) with `aws s3api` due to the fact that it can not use our optimization to skip the whole prefix. It is independant from my refactor and can be tested with the commented `s3api` tests in `test-smoke.sh`. It probably has the same weird behavior on the official AWS S3 implementation. - Considering ListMultipartUploads, I had to "abuse" upload id marker to support prefix skipping. I send an `upload-id-marker` with the hardcoded value `include` to emulate your "including" token. - Some ways to test ListMultipartUploads with existing software (my tests are limited to s3api for now). Co-authored-by: Quentin Dufour <quentin@deuxfleurs.fr> Reviewed-on: https://git.deuxfleurs.fr/Deuxfleurs/garage/pulls/171 Co-authored-by: Quentin <quentin@dufour.io> Co-committed-by: Quentin <quentin@dufour.io>
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/default.nix b/default.nix
index e0336174..faf6f522 100644
--- a/default.nix
+++ b/default.nix
@@ -24,6 +24,11 @@ in let
rustChannel = pkgs.rustPlatform.rust;
overrides = pkgs.buildPackages.rustBuilder.overrides.all ++ [
+ /*
+ We want to inject the git version while keeping the build deterministic.
+ As we do not want to consider the .git folder as part of the input source,
+ we ask the user (the CI often) to pass the value to Nix.
+ */
(pkgs.rustBuilder.rustLib.makeOverride {
name = "garage";
overrideAttrs = drv: if git_version != null then {
@@ -33,6 +38,21 @@ in let
'';
} else {};
})
+
+ /*
+ On a sandbox pure NixOS environment, /usr/bin/file is not available.
+ This is a known problem: https://github.com/NixOS/nixpkgs/issues/98440
+ We simply patch the file as suggested
+ */
+ /*(pkgs.rustBuilder.rustLib.makeOverride {
+ name = "libsodium-sys";
+ overrideAttrs = drv: {
+ preConfigure = ''
+ ${drv.preConfigure or ""}
+ sed -i 's,/usr/bin/file,${file}/bin/file,g' ./configure
+ '';
+ }
+ })*/
];
packageFun = import ./Cargo.nix;