aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorAlex Auvolat <alex@adnab.me>2020-04-21 20:37:02 +0000
committerAlex Auvolat <alex@adnab.me>2020-04-21 20:37:02 +0000
commitc0335ac6904598b9ac367e17651da477d4d970d7 (patch)
treecc462d33af8c6883e541efcbd5fb05dbe22429a7 /Cargo.toml
parentec59e896c6cf405a0e52392ebb8619f26a367968 (diff)
downloadgarage-c0335ac6904598b9ac367e17651da477d4d970d7.tar.gz
garage-c0335ac6904598b9ac367e17651da477d4d970d7.zip
Remove a few features in dependencies
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml5
1 files changed, 2 insertions, 3 deletions
diff --git a/Cargo.toml b/Cargo.toml
index e6c27b4a..13033694 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -22,16 +22,15 @@ sled = "0.31"
structopt = { version = "0.3", default-features = false }
toml = "0.5"
rmp-serde = "0.14.3"
-serde = { version = "1.0", features = ["derive", "rc"] }
+serde = { version = "1.0", default-features = false, features = ["derive", "rc"] }
serde_bytes = "0.11"
serde_json = "1.0"
async-trait = "0.1.30"
futures = "0.3"
futures-core = "0.3"
-futures-channel = "0.3"
futures-util = "0.3"
-tokio = { version = "0.2", features = ["full"] }
+tokio = { version = "0.2", default-features = false, features = ["rt-core", "rt-threaded", "io-driver", "net", "tcp", "time", "macros", "sync", "signal", "fs"] }
http = "0.2"
hyper = "0.13"