aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2024-04-23 11:57:43 +0300
committerFlorian Klink <flokli@flokli.de>2024-06-05 08:41:36 +0200
commita0f6bc5b7faa0d557179a7c4ed4c8d0facb9afa4 (patch)
treea16e5b4d951c793bbd7f6ef62a66d15e7c4605c6 /Cargo.toml
parenta2c1de646bce4a96cf8dc526f82bd88bcf3dde70 (diff)
downloadgarage-a0f6bc5b7faa0d557179a7c4ed4c8d0facb9afa4.tar.gz
garage-a0f6bc5b7faa0d557179a7c4ed4c8d0facb9afa4.zip
add rpc_public_addr_subnet config option
In case `rpc_public_addr` is not set, but autodiscovery is used, this allows filtering the list of automatically discovered IPs to a specific subnet. For example, if nodes should pick *their* IP inside a specific subnet, but you don't want to explicitly write the IP down (as it's dynamic, or you want to share configs across nodes), you can use this option.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index b8840a91..500079f2 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -55,6 +55,7 @@ hexdump = "0.1"
hmac = "0.12"
idna = "0.5"
itertools = "0.12"
+ipnet = "2.9.0"
lazy_static = "1.4"
md-5 = "0.10"
mktemp = "0.5"