aboutsummaryrefslogtreecommitdiff
path: root/Cargo.nix
diff options
context:
space:
mode:
authorAlex Auvolat <alex@adnab.me>2024-04-08 11:18:19 +0200
committerAlex Auvolat <alex@adnab.me>2024-04-08 11:18:19 +0200
commit7dd7cb5759635b3a1c18660a171bd34a10043f6c (patch)
tree0a89132b19562d5a6d48b69ad4318755f5a7216d /Cargo.nix
parent8b663d8c5bccae2ccc831941779523c407bf43a5 (diff)
downloadgarage-7dd7cb5759635b3a1c18660a171bd34a10043f6c.tar.gz
garage-7dd7cb5759635b3a1c18660a171bd34a10043f6c.zip
[rel-0.9.4] upgrade version to v0.9.4v0.9.4
Diffstat (limited to 'Cargo.nix')
-rw-r--r--Cargo.nix138
1 files changed, 69 insertions, 69 deletions
diff --git a/Cargo.nix b/Cargo.nix
index 44cb23b5..d08f6e6a 100644
--- a/Cargo.nix
+++ b/Cargo.nix
@@ -34,7 +34,7 @@ args@{
ignoreLockHash,
}:
let
- nixifiedLockHash = "1d6c837fe8357cbb1b231c1843bde1729c9864f05e5ae251be045450a0b592e3";
+ nixifiedLockHash = "9ea4045dd09421583b69811f95797af9c1f16239ecce89d8a6f5a9319d7d8526";
workspaceSrc = if args.workspaceSrc == null then ./. else args.workspaceSrc;
currentLockHash = builtins.hashFile "sha256" (workspaceSrc + /Cargo.lock);
lockHashIgnored = if ignoreLockHash
@@ -58,17 +58,17 @@ in
{
cargo2nixVersion = "0.11.0";
workspace = {
- garage_db = rustPackages.unknown.garage_db."0.9.3";
- garage_util = rustPackages.unknown.garage_util."0.9.3";
- garage_net = rustPackages.unknown.garage_net."0.9.3";
- garage_rpc = rustPackages.unknown.garage_rpc."0.9.3";
+ garage_db = rustPackages.unknown.garage_db."0.9.4";
+ garage_util = rustPackages.unknown.garage_util."0.9.4";
+ garage_net = rustPackages.unknown.garage_net."0.9.4";
+ garage_rpc = rustPackages.unknown.garage_rpc."0.9.4";
format_table = rustPackages.unknown.format_table."0.1.1";
- garage_table = rustPackages.unknown.garage_table."0.9.3";
- garage_block = rustPackages.unknown.garage_block."0.9.3";
- garage_model = rustPackages.unknown.garage_model."0.9.3";
- garage_api = rustPackages.unknown.garage_api."0.9.3";
- garage_web = rustPackages.unknown.garage_web."0.9.3";
- garage = rustPackages.unknown.garage."0.9.3";
+ garage_table = rustPackages.unknown.garage_table."0.9.4";
+ garage_block = rustPackages.unknown.garage_block."0.9.4";
+ garage_model = rustPackages.unknown.garage_model."0.9.4";
+ garage_api = rustPackages.unknown.garage_api."0.9.4";
+ garage_web = rustPackages.unknown.garage_web."0.9.4";
+ garage = rustPackages.unknown.garage."0.9.4";
k2v-client = rustPackages.unknown.k2v-client."0.0.4";
};
"registry+https://github.com/rust-lang/crates.io-index".addr2line."0.21.0" = overridableMkRustCrate (profileName: rec {
@@ -1871,9 +1871,9 @@ in
};
});
- "unknown".garage."0.9.3" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage."0.9.4" = overridableMkRustCrate (profileName: rec {
name = "garage";
- version = "0.9.3";
+ version = "0.9.4";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/garage");
features = builtins.concatLists [
@@ -1902,15 +1902,15 @@ in
format_table = (rustPackages."unknown".format_table."0.1.1" { inherit profileName; }).out;
futures = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures."0.3.30" { inherit profileName; }).out;
futures_util = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures-util."0.3.30" { inherit profileName; }).out;
- garage_api = (rustPackages."unknown".garage_api."0.9.3" { inherit profileName; }).out;
- garage_block = (rustPackages."unknown".garage_block."0.9.3" { inherit profileName; }).out;
- garage_db = (rustPackages."unknown".garage_db."0.9.3" { inherit profileName; }).out;
- garage_model = (rustPackages."unknown".garage_model."0.9.3" { inherit profileName; }).out;
- garage_net = (rustPackages."unknown".garage_net."0.9.3" { inherit profileName; }).out;
- garage_rpc = (rustPackages."unknown".garage_rpc."0.9.3" { inherit profileName; }).out;
- garage_table = (rustPackages."unknown".garage_table."0.9.3" { inherit profileName; }).out;
- garage_util = (rustPackages."unknown".garage_util."0.9.3" { inherit profileName; }).out;
- garage_web = (rustPackages."unknown".garage_web."0.9.3" { inherit profileName; }).out;
+ garage_api = (rustPackages."unknown".garage_api."0.9.4" { inherit profileName; }).out;
+ garage_block = (rustPackages."unknown".garage_block."0.9.4" { inherit profileName; }).out;
+ garage_db = (rustPackages."unknown".garage_db."0.9.4" { inherit profileName; }).out;
+ garage_model = (rustPackages."unknown".garage_model."0.9.4" { inherit profileName; }).out;
+ garage_net = (rustPackages."unknown".garage_net."0.9.4" { inherit profileName; }).out;
+ garage_rpc = (rustPackages."unknown".garage_rpc."0.9.4" { inherit profileName; }).out;
+ garage_table = (rustPackages."unknown".garage_table."0.9.4" { inherit profileName; }).out;
+ garage_util = (rustPackages."unknown".garage_util."0.9.4" { inherit profileName; }).out;
+ garage_web = (rustPackages."unknown".garage_web."0.9.4" { inherit profileName; }).out;
git_version = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".git-version."0.3.9" { inherit profileName; }).out;
hex = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hex."0.4.3" { inherit profileName; }).out;
sodiumoxide = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".kuska-sodiumoxide."0.2.5-0" { inherit profileName; }).out;
@@ -1949,9 +1949,9 @@ in
};
});
- "unknown".garage_api."0.9.3" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage_api."0.9.4" = overridableMkRustCrate (profileName: rec {
name = "garage_api";
- version = "0.9.3";
+ version = "0.9.4";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/api");
features = builtins.concatLists [
@@ -1971,12 +1971,12 @@ in
form_urlencoded = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".form_urlencoded."1.2.1" { inherit profileName; }).out;
futures = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures."0.3.30" { inherit profileName; }).out;
futures_util = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures-util."0.3.30" { inherit profileName; }).out;
- garage_block = (rustPackages."unknown".garage_block."0.9.3" { inherit profileName; }).out;
- garage_model = (rustPackages."unknown".garage_model."0.9.3" { inherit profileName; }).out;
- garage_net = (rustPackages."unknown".garage_net."0.9.3" { inherit profileName; }).out;
- garage_rpc = (rustPackages."unknown".garage_rpc."0.9.3" { inherit profileName; }).out;
- garage_table = (rustPackages."unknown".garage_table."0.9.3" { inherit profileName; }).out;
- garage_util = (rustPackages."unknown".garage_util."0.9.3" { inherit profileName; }).out;
+ garage_block = (rustPackages."unknown".garage_block."0.9.4" { inherit profileName; }).out;
+ garage_model = (rustPackages."unknown".garage_model."0.9.4" { inherit profileName; }).out;
+ garage_net = (rustPackages."unknown".garage_net."0.9.4" { inherit profileName; }).out;
+ garage_rpc = (rustPackages."unknown".garage_rpc."0.9.4" { inherit profileName; }).out;
+ garage_table = (rustPackages."unknown".garage_table."0.9.4" { inherit profileName; }).out;
+ garage_util = (rustPackages."unknown".garage_util."0.9.4" { inherit profileName; }).out;
hex = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hex."0.4.3" { inherit profileName; }).out;
hmac = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hmac."0.12.1" { inherit profileName; }).out;
http = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".http."1.0.0" { inherit profileName; }).out;
@@ -2007,9 +2007,9 @@ in
};
});
- "unknown".garage_block."0.9.3" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage_block."0.9.4" = overridableMkRustCrate (profileName: rec {
name = "garage_block";
- version = "0.9.3";
+ version = "0.9.4";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/block");
features = builtins.concatLists [
@@ -2023,11 +2023,11 @@ in
bytesize = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".bytesize."1.3.0" { inherit profileName; }).out;
futures = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures."0.3.30" { inherit profileName; }).out;
futures_util = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures-util."0.3.30" { inherit profileName; }).out;
- garage_db = (rustPackages."unknown".garage_db."0.9.3" { inherit profileName; }).out;
- garage_net = (rustPackages."unknown".garage_net."0.9.3" { inherit profileName; }).out;
- garage_rpc = (rustPackages."unknown".garage_rpc."0.9.3" { inherit profileName; }).out;
- garage_table = (rustPackages."unknown".garage_table."0.9.3" { inherit profileName; }).out;
- garage_util = (rustPackages."unknown".garage_util."0.9.3" { inherit profileName; }).out;
+ garage_db = (rustPackages."unknown".garage_db."0.9.4" { inherit profileName; }).out;
+ garage_net = (rustPackages."unknown".garage_net."0.9.4" { inherit profileName; }).out;
+ garage_rpc = (rustPackages."unknown".garage_rpc."0.9.4" { inherit profileName; }).out;
+ garage_table = (rustPackages."unknown".garage_table."0.9.4" { inherit profileName; }).out;
+ garage_util = (rustPackages."unknown".garage_util."0.9.4" { inherit profileName; }).out;
hex = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hex."0.4.3" { inherit profileName; }).out;
opentelemetry = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".opentelemetry."0.17.0" { inherit profileName; }).out;
rand = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".rand."0.8.5" { inherit profileName; }).out;
@@ -2040,9 +2040,9 @@ in
};
});
- "unknown".garage_db."0.9.3" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage_db."0.9.4" = overridableMkRustCrate (profileName: rec {
name = "garage_db";
- version = "0.9.3";
+ version = "0.9.4";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/db");
features = builtins.concatLists [
@@ -2071,9 +2071,9 @@ in
};
});
- "unknown".garage_model."0.9.3" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage_model."0.9.4" = overridableMkRustCrate (profileName: rec {
name = "garage_model";
- version = "0.9.3";
+ version = "0.9.4";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/model");
features = builtins.concatLists [
@@ -2092,12 +2092,12 @@ in
err_derive = (buildRustPackages."registry+https://github.com/rust-lang/crates.io-index".err-derive."0.3.1" { profileName = "__noProfile"; }).out;
futures = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures."0.3.30" { inherit profileName; }).out;
futures_util = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures-util."0.3.30" { inherit profileName; }).out;
- garage_block = (rustPackages."unknown".garage_block."0.9.3" { inherit profileName; }).out;
- garage_db = (rustPackages."unknown".garage_db."0.9.3" { inherit profileName; }).out;
- garage_net = (rustPackages."unknown".garage_net."0.9.3" { inherit profileName; }).out;
- garage_rpc = (rustPackages."unknown".garage_rpc."0.9.3" { inherit profileName; }).out;
- garage_table = (rustPackages."unknown".garage_table."0.9.3" { inherit profileName; }).out;
- garage_util = (rustPackages."unknown".garage_util."0.9.3" { inherit profileName; }).out;
+ garage_block = (rustPackages."unknown".garage_block."0.9.4" { inherit profileName; }).out;
+ garage_db = (rustPackages."unknown".garage_db."0.9.4" { inherit profileName; }).out;
+ garage_net = (rustPackages."unknown".garage_net."0.9.4" { inherit profileName; }).out;
+ garage_rpc = (rustPackages."unknown".garage_rpc."0.9.4" { inherit profileName; }).out;
+ garage_table = (rustPackages."unknown".garage_table."0.9.4" { inherit profileName; }).out;
+ garage_util = (rustPackages."unknown".garage_util."0.9.4" { inherit profileName; }).out;
hex = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hex."0.4.3" { inherit profileName; }).out;
opentelemetry = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".opentelemetry."0.17.0" { inherit profileName; }).out;
parse_duration = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".parse_duration."2.1.1" { inherit profileName; }).out;
@@ -2110,9 +2110,9 @@ in
};
});
- "unknown".garage_net."0.9.3" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage_net."0.9.4" = overridableMkRustCrate (profileName: rec {
name = "garage_net";
- version = "0.9.3";
+ version = "0.9.4";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/net");
features = builtins.concatLists [
@@ -2147,9 +2147,9 @@ in
};
});
- "unknown".garage_rpc."0.9.3" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage_rpc."0.9.4" = overridableMkRustCrate (profileName: rec {
name = "garage_rpc";
- version = "0.9.3";
+ version = "0.9.4";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/rpc");
features = builtins.concatLists [
@@ -2171,9 +2171,9 @@ in
format_table = (rustPackages."unknown".format_table."0.1.1" { inherit profileName; }).out;
futures = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures."0.3.30" { inherit profileName; }).out;
futures_util = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures-util."0.3.30" { inherit profileName; }).out;
- garage_db = (rustPackages."unknown".garage_db."0.9.3" { inherit profileName; }).out;
- garage_net = (rustPackages."unknown".garage_net."0.9.3" { inherit profileName; }).out;
- garage_util = (rustPackages."unknown".garage_util."0.9.3" { inherit profileName; }).out;
+ garage_db = (rustPackages."unknown".garage_db."0.9.4" { inherit profileName; }).out;
+ garage_net = (rustPackages."unknown".garage_net."0.9.4" { inherit profileName; }).out;
+ garage_util = (rustPackages."unknown".garage_util."0.9.4" { inherit profileName; }).out;
gethostname = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".gethostname."0.4.3" { inherit profileName; }).out;
hex = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hex."0.4.3" { inherit profileName; }).out;
itertools = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".itertools."0.12.1" { inherit profileName; }).out;
@@ -2195,9 +2195,9 @@ in
};
});
- "unknown".garage_table."0.9.3" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage_table."0.9.4" = overridableMkRustCrate (profileName: rec {
name = "garage_table";
- version = "0.9.3";
+ version = "0.9.4";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/table");
dependencies = {
@@ -2206,9 +2206,9 @@ in
bytes = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".bytes."1.5.0" { inherit profileName; }).out;
futures = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures."0.3.30" { inherit profileName; }).out;
futures_util = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures-util."0.3.30" { inherit profileName; }).out;
- garage_db = (rustPackages."unknown".garage_db."0.9.3" { inherit profileName; }).out;
- garage_rpc = (rustPackages."unknown".garage_rpc."0.9.3" { inherit profileName; }).out;
- garage_util = (rustPackages."unknown".garage_util."0.9.3" { inherit profileName; }).out;
+ garage_db = (rustPackages."unknown".garage_db."0.9.4" { inherit profileName; }).out;
+ garage_rpc = (rustPackages."unknown".garage_rpc."0.9.4" { inherit profileName; }).out;
+ garage_util = (rustPackages."unknown".garage_util."0.9.4" { inherit profileName; }).out;
hex = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hex."0.4.3" { inherit profileName; }).out;
hexdump = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hexdump."0.1.1" { inherit profileName; }).out;
opentelemetry = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".opentelemetry."0.17.0" { inherit profileName; }).out;
@@ -2220,9 +2220,9 @@ in
};
});
- "unknown".garage_util."0.9.3" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage_util."0.9.4" = overridableMkRustCrate (profileName: rec {
name = "garage_util";
- version = "0.9.3";
+ version = "0.9.4";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/util");
features = builtins.concatLists [
@@ -2238,8 +2238,8 @@ in
digest = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".digest."0.10.7" { inherit profileName; }).out;
err_derive = (buildRustPackages."registry+https://github.com/rust-lang/crates.io-index".err-derive."0.3.1" { profileName = "__noProfile"; }).out;
futures = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures."0.3.30" { inherit profileName; }).out;
- garage_db = (rustPackages."unknown".garage_db."0.9.3" { inherit profileName; }).out;
- garage_net = (rustPackages."unknown".garage_net."0.9.3" { inherit profileName; }).out;
+ garage_db = (rustPackages."unknown".garage_db."0.9.4" { inherit profileName; }).out;
+ garage_net = (rustPackages."unknown".garage_net."0.9.4" { inherit profileName; }).out;
hex = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hex."0.4.3" { inherit profileName; }).out;
hexdump = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hexdump."0.1.1" { inherit profileName; }).out;
http = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".http."1.0.0" { inherit profileName; }).out;
@@ -2264,18 +2264,18 @@ in
};
});
- "unknown".garage_web."0.9.3" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage_web."0.9.4" = overridableMkRustCrate (profileName: rec {
name = "garage_web";
- version = "0.9.3";
+ version = "0.9.4";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/web");
dependencies = {
err_derive = (buildRustPackages."registry+https://github.com/rust-lang/crates.io-index".err-derive."0.3.1" { profileName = "__noProfile"; }).out;
futures = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures."0.3.30" { inherit profileName; }).out;
- garage_api = (rustPackages."unknown".garage_api."0.9.3" { inherit profileName; }).out;
- garage_model = (rustPackages."unknown".garage_model."0.9.3" { inherit profileName; }).out;
- garage_table = (rustPackages."unknown".garage_table."0.9.3" { inherit profileName; }).out;
- garage_util = (rustPackages."unknown".garage_util."0.9.3" { inherit profileName; }).out;
+ garage_api = (rustPackages."unknown".garage_api."0.9.4" { inherit profileName; }).out;
+ garage_model = (rustPackages."unknown".garage_model."0.9.4" { inherit profileName; }).out;
+ garage_table = (rustPackages."unknown".garage_table."0.9.4" { inherit profileName; }).out;
+ garage_util = (rustPackages."unknown".garage_util."0.9.4" { inherit profileName; }).out;
http = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".http."1.0.0" { inherit profileName; }).out;
http_body_util = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".http-body-util."0.1.0" { inherit profileName; }).out;
hyper = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hyper."1.1.0" { inherit profileName; }).out;