aboutsummaryrefslogtreecommitdiff
path: root/Cargo.nix
diff options
context:
space:
mode:
authorAlex Auvolat <alex@adnab.me>2023-09-05 23:28:12 +0200
committerAlex Auvolat <alex@adnab.me>2023-09-05 23:28:12 +0200
commit51eac97260d768d0f1f93680fad95787f7e42e72 (patch)
tree6d71885b7df3b76b2e9c0b830a678450c285327f /Cargo.nix
parente78566591b6fc2ff67a1b9beec064b6a7e605e6f (diff)
downloadgarage-51eac97260d768d0f1f93680fad95787f7e42e72.tar.gz
garage-51eac97260d768d0f1f93680fad95787f7e42e72.zip
update version to 0.8.4v0.8.4hold-netapp-0.5.2
Diffstat (limited to 'Cargo.nix')
-rw-r--r--Cargo.nix123
1 files changed, 61 insertions, 62 deletions
diff --git a/Cargo.nix b/Cargo.nix
index f2da2492..9e458f88 100644
--- a/Cargo.nix
+++ b/Cargo.nix
@@ -24,7 +24,6 @@ args@{
target ? null,
codegenOpts ? null,
profileOpts ? null,
- cargoUnstableFlags ? null,
rustcLinkFlags ? null,
rustcBuildFlags ? null,
mkRustCrate,
@@ -34,7 +33,7 @@ args@{
ignoreLockHash,
}:
let
- nixifiedLockHash = "22bbf553d627a8e75e4f63b540267fbfb874cfdb7bf6e76efc2332e7eddfc80d";
+ nixifiedLockHash = "b958f9aca0ee3fb1f7b52b15508132d0a96480a7f43f83e0da6609c0fe1812ef";
workspaceSrc = if args.workspaceSrc == null then ./. else args.workspaceSrc;
currentLockHash = builtins.hashFile "sha256" (workspaceSrc + /Cargo.lock);
lockHashIgnored = if ignoreLockHash
@@ -51,22 +50,22 @@ else let
rootFeatures' = expandFeatures rootFeatures;
overridableMkRustCrate = f:
let
- drvs = genDrvsByProfile profilesByName ({ profile, profileName }: mkRustCrate ({ inherit release profile hostPlatformCpu hostPlatformFeatures target profileOpts codegenOpts cargoUnstableFlags rustcLinkFlags rustcBuildFlags; } // (f profileName)));
+ drvs = genDrvsByProfile profilesByName ({ profile, profileName }: mkRustCrate ({ inherit release profile hostPlatformCpu hostPlatformFeatures target profileOpts codegenOpts rustcLinkFlags rustcBuildFlags; } // (f profileName)));
in { compileMode ? null, profileName ? decideProfile compileMode release }:
let drv = drvs.${profileName}; in if compileMode == null then drv else drv.override { inherit compileMode; };
in
{
cargo2nixVersion = "0.11.0";
workspace = {
- garage_db = rustPackages.unknown.garage_db."0.8.3";
- garage_util = rustPackages.unknown.garage_util."0.8.3";
- garage_rpc = rustPackages.unknown.garage_rpc."0.8.3";
- garage_table = rustPackages.unknown.garage_table."0.8.3";
- garage_block = rustPackages.unknown.garage_block."0.8.3";
- garage_model = rustPackages.unknown.garage_model."0.8.3";
- garage_api = rustPackages.unknown.garage_api."0.8.3";
- garage_web = rustPackages.unknown.garage_web."0.8.3";
- garage = rustPackages.unknown.garage."0.8.3";
+ garage_db = rustPackages.unknown.garage_db."0.8.4";
+ garage_util = rustPackages.unknown.garage_util."0.8.4";
+ garage_rpc = rustPackages.unknown.garage_rpc."0.8.4";
+ garage_table = rustPackages.unknown.garage_table."0.8.4";
+ garage_block = rustPackages.unknown.garage_block."0.8.4";
+ garage_model = rustPackages.unknown.garage_model."0.8.4";
+ garage_api = rustPackages.unknown.garage_api."0.8.4";
+ garage_web = rustPackages.unknown.garage_web."0.8.4";
+ garage = rustPackages.unknown.garage."0.8.4";
format_table = rustPackages.unknown.format_table."0.1.1";
k2v-client = rustPackages.unknown.k2v-client."0.0.4";
};
@@ -1706,9 +1705,9 @@ in
};
});
- "unknown".garage."0.8.3" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage."0.8.4" = overridableMkRustCrate (profileName: rec {
name = "garage";
- version = "0.8.3";
+ version = "0.8.4";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/garage");
features = builtins.concatLists [
@@ -1735,14 +1734,14 @@ in
format_table = (rustPackages."unknown".format_table."0.1.1" { inherit profileName; }).out;
futures = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures."0.3.28" { inherit profileName; }).out;
futures_util = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures-util."0.3.28" { inherit profileName; }).out;
- garage_api = (rustPackages."unknown".garage_api."0.8.3" { inherit profileName; }).out;
- garage_block = (rustPackages."unknown".garage_block."0.8.3" { inherit profileName; }).out;
- garage_db = (rustPackages."unknown".garage_db."0.8.3" { inherit profileName; }).out;
- garage_model = (rustPackages."unknown".garage_model."0.8.3" { inherit profileName; }).out;
- garage_rpc = (rustPackages."unknown".garage_rpc."0.8.3" { inherit profileName; }).out;
- garage_table = (rustPackages."unknown".garage_table."0.8.3" { inherit profileName; }).out;
- garage_util = (rustPackages."unknown".garage_util."0.8.3" { inherit profileName; }).out;
- garage_web = (rustPackages."unknown".garage_web."0.8.3" { inherit profileName; }).out;
+ garage_api = (rustPackages."unknown".garage_api."0.8.4" { inherit profileName; }).out;
+ garage_block = (rustPackages."unknown".garage_block."0.8.4" { inherit profileName; }).out;
+ garage_db = (rustPackages."unknown".garage_db."0.8.4" { inherit profileName; }).out;
+ garage_model = (rustPackages."unknown".garage_model."0.8.4" { inherit profileName; }).out;
+ garage_rpc = (rustPackages."unknown".garage_rpc."0.8.4" { inherit profileName; }).out;
+ garage_table = (rustPackages."unknown".garage_table."0.8.4" { inherit profileName; }).out;
+ garage_util = (rustPackages."unknown".garage_util."0.8.4" { inherit profileName; }).out;
+ garage_web = (rustPackages."unknown".garage_web."0.8.4" { inherit profileName; }).out;
git_version = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".git-version."0.3.5" { inherit profileName; }).out;
hex = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hex."0.4.3" { inherit profileName; }).out;
sodiumoxide = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".kuska-sodiumoxide."0.2.5-0" { inherit profileName; }).out;
@@ -1778,9 +1777,9 @@ in
};
});
- "unknown".garage_api."0.8.3" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage_api."0.8.4" = overridableMkRustCrate (profileName: rec {
name = "garage_api";
- version = "0.8.3";
+ version = "0.8.4";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/api");
features = builtins.concatLists [
@@ -1799,11 +1798,11 @@ in
form_urlencoded = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".form_urlencoded."1.2.0" { inherit profileName; }).out;
futures = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures."0.3.28" { inherit profileName; }).out;
futures_util = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures-util."0.3.28" { inherit profileName; }).out;
- garage_block = (rustPackages."unknown".garage_block."0.8.3" { inherit profileName; }).out;
- garage_model = (rustPackages."unknown".garage_model."0.8.3" { inherit profileName; }).out;
- garage_rpc = (rustPackages."unknown".garage_rpc."0.8.3" { inherit profileName; }).out;
- garage_table = (rustPackages."unknown".garage_table."0.8.3" { inherit profileName; }).out;
- garage_util = (rustPackages."unknown".garage_util."0.8.3" { inherit profileName; }).out;
+ garage_block = (rustPackages."unknown".garage_block."0.8.4" { inherit profileName; }).out;
+ garage_model = (rustPackages."unknown".garage_model."0.8.4" { inherit profileName; }).out;
+ garage_rpc = (rustPackages."unknown".garage_rpc."0.8.4" { inherit profileName; }).out;
+ garage_table = (rustPackages."unknown".garage_table."0.8.4" { inherit profileName; }).out;
+ garage_util = (rustPackages."unknown".garage_util."0.8.4" { inherit profileName; }).out;
hex = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hex."0.4.3" { inherit profileName; }).out;
hmac = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hmac."0.12.1" { inherit profileName; }).out;
http = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".http."0.2.9" { inherit profileName; }).out;
@@ -1832,9 +1831,9 @@ in
};
});
- "unknown".garage_block."0.8.3" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage_block."0.8.4" = overridableMkRustCrate (profileName: rec {
name = "garage_block";
- version = "0.8.3";
+ version = "0.8.4";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/block");
features = builtins.concatLists [
@@ -1847,10 +1846,10 @@ in
bytes = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".bytes."1.4.0" { inherit profileName; }).out;
futures = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures."0.3.28" { inherit profileName; }).out;
futures_util = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures-util."0.3.28" { inherit profileName; }).out;
- garage_db = (rustPackages."unknown".garage_db."0.8.3" { inherit profileName; }).out;
- garage_rpc = (rustPackages."unknown".garage_rpc."0.8.3" { inherit profileName; }).out;
- garage_table = (rustPackages."unknown".garage_table."0.8.3" { inherit profileName; }).out;
- garage_util = (rustPackages."unknown".garage_util."0.8.3" { inherit profileName; }).out;
+ garage_db = (rustPackages."unknown".garage_db."0.8.4" { inherit profileName; }).out;
+ garage_rpc = (rustPackages."unknown".garage_rpc."0.8.4" { inherit profileName; }).out;
+ garage_table = (rustPackages."unknown".garage_table."0.8.4" { inherit profileName; }).out;
+ garage_util = (rustPackages."unknown".garage_util."0.8.4" { inherit profileName; }).out;
hex = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hex."0.4.3" { inherit profileName; }).out;
opentelemetry = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".opentelemetry."0.17.0" { inherit profileName; }).out;
rand = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".rand."0.8.5" { inherit profileName; }).out;
@@ -1863,9 +1862,9 @@ in
};
});
- "unknown".garage_db."0.8.3" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage_db."0.8.4" = overridableMkRustCrate (profileName: rec {
name = "garage_db";
- version = "0.8.3";
+ version = "0.8.4";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/db");
features = builtins.concatLists [
@@ -1895,9 +1894,9 @@ in
};
});
- "unknown".garage_model."0.8.3" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage_model."0.8.4" = overridableMkRustCrate (profileName: rec {
name = "garage_model";
- version = "0.8.3";
+ version = "0.8.4";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/model");
features = builtins.concatLists [
@@ -1915,11 +1914,11 @@ in
err_derive = (buildRustPackages."registry+https://github.com/rust-lang/crates.io-index".err-derive."0.3.1" { profileName = "__noProfile"; }).out;
futures = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures."0.3.28" { inherit profileName; }).out;
futures_util = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures-util."0.3.28" { inherit profileName; }).out;
- garage_block = (rustPackages."unknown".garage_block."0.8.3" { inherit profileName; }).out;
- garage_db = (rustPackages."unknown".garage_db."0.8.3" { inherit profileName; }).out;
- garage_rpc = (rustPackages."unknown".garage_rpc."0.8.3" { inherit profileName; }).out;
- garage_table = (rustPackages."unknown".garage_table."0.8.3" { inherit profileName; }).out;
- garage_util = (rustPackages."unknown".garage_util."0.8.3" { inherit profileName; }).out;
+ garage_block = (rustPackages."unknown".garage_block."0.8.4" { inherit profileName; }).out;
+ garage_db = (rustPackages."unknown".garage_db."0.8.4" { inherit profileName; }).out;
+ garage_rpc = (rustPackages."unknown".garage_rpc."0.8.4" { inherit profileName; }).out;
+ garage_table = (rustPackages."unknown".garage_table."0.8.4" { inherit profileName; }).out;
+ garage_util = (rustPackages."unknown".garage_util."0.8.4" { inherit profileName; }).out;
hex = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hex."0.4.3" { inherit profileName; }).out;
netapp = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".netapp."0.5.2" { inherit profileName; }).out;
opentelemetry = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".opentelemetry."0.17.0" { inherit profileName; }).out;
@@ -1932,9 +1931,9 @@ in
};
});
- "unknown".garage_rpc."0.8.3" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage_rpc."0.8.4" = overridableMkRustCrate (profileName: rec {
name = "garage_rpc";
- version = "0.8.3";
+ version = "0.8.4";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/rpc");
features = builtins.concatLists [
@@ -1954,8 +1953,8 @@ in
${ if rootFeatures' ? "garage/consul-discovery" || rootFeatures' ? "garage_rpc/consul-discovery" || rootFeatures' ? "garage_rpc/err-derive" then "err_derive" else null } = (buildRustPackages."registry+https://github.com/rust-lang/crates.io-index".err-derive."0.3.1" { profileName = "__noProfile"; }).out;
futures = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures."0.3.28" { inherit profileName; }).out;
futures_util = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures-util."0.3.28" { inherit profileName; }).out;
- garage_db = (rustPackages."unknown".garage_db."0.8.3" { inherit profileName; }).out;
- garage_util = (rustPackages."unknown".garage_util."0.8.3" { inherit profileName; }).out;
+ garage_db = (rustPackages."unknown".garage_db."0.8.4" { inherit profileName; }).out;
+ garage_util = (rustPackages."unknown".garage_util."0.8.4" { inherit profileName; }).out;
gethostname = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".gethostname."0.4.3" { inherit profileName; }).out;
hex = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hex."0.4.3" { inherit profileName; }).out;
${ if rootFeatures' ? "garage/kubernetes-discovery" || rootFeatures' ? "garage_rpc/k8s-openapi" || rootFeatures' ? "garage_rpc/kubernetes-discovery" then "k8s_openapi" else null } = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".k8s-openapi."0.16.0" { inherit profileName; }).out;
@@ -1977,9 +1976,9 @@ in
};
});
- "unknown".garage_table."0.8.3" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage_table."0.8.4" = overridableMkRustCrate (profileName: rec {
name = "garage_table";
- version = "0.8.3";
+ version = "0.8.4";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/table");
dependencies = {
@@ -1988,9 +1987,9 @@ in
bytes = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".bytes."1.4.0" { inherit profileName; }).out;
futures = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures."0.3.28" { inherit profileName; }).out;
futures_util = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures-util."0.3.28" { inherit profileName; }).out;
- garage_db = (rustPackages."unknown".garage_db."0.8.3" { inherit profileName; }).out;
- garage_rpc = (rustPackages."unknown".garage_rpc."0.8.3" { inherit profileName; }).out;
- garage_util = (rustPackages."unknown".garage_util."0.8.3" { inherit profileName; }).out;
+ garage_db = (rustPackages."unknown".garage_db."0.8.4" { inherit profileName; }).out;
+ garage_rpc = (rustPackages."unknown".garage_rpc."0.8.4" { inherit profileName; }).out;
+ garage_util = (rustPackages."unknown".garage_util."0.8.4" { inherit profileName; }).out;
hex = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hex."0.4.3" { inherit profileName; }).out;
hexdump = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hexdump."0.1.1" { inherit profileName; }).out;
opentelemetry = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".opentelemetry."0.17.0" { inherit profileName; }).out;
@@ -2002,9 +2001,9 @@ in
};
});
- "unknown".garage_util."0.8.3" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage_util."0.8.4" = overridableMkRustCrate (profileName: rec {
name = "garage_util";
- version = "0.8.3";
+ version = "0.8.4";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/util");
features = builtins.concatLists [
@@ -2019,7 +2018,7 @@ in
digest = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".digest."0.10.7" { inherit profileName; }).out;
err_derive = (buildRustPackages."registry+https://github.com/rust-lang/crates.io-index".err-derive."0.3.1" { profileName = "__noProfile"; }).out;
futures = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures."0.3.28" { inherit profileName; }).out;
- garage_db = (rustPackages."unknown".garage_db."0.8.3" { inherit profileName; }).out;
+ garage_db = (rustPackages."unknown".garage_db."0.8.4" { inherit profileName; }).out;
hex = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hex."0.4.3" { inherit profileName; }).out;
hexdump = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hexdump."0.1.1" { inherit profileName; }).out;
http = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".http."0.2.9" { inherit profileName; }).out;
@@ -2045,18 +2044,18 @@ in
};
});
- "unknown".garage_web."0.8.3" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage_web."0.8.4" = overridableMkRustCrate (profileName: rec {
name = "garage_web";
- version = "0.8.3";
+ version = "0.8.4";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/web");
dependencies = {
err_derive = (buildRustPackages."registry+https://github.com/rust-lang/crates.io-index".err-derive."0.3.1" { profileName = "__noProfile"; }).out;
futures = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures."0.3.28" { inherit profileName; }).out;
- garage_api = (rustPackages."unknown".garage_api."0.8.3" { inherit profileName; }).out;
- garage_model = (rustPackages."unknown".garage_model."0.8.3" { inherit profileName; }).out;
- garage_table = (rustPackages."unknown".garage_table."0.8.3" { inherit profileName; }).out;
- garage_util = (rustPackages."unknown".garage_util."0.8.3" { inherit profileName; }).out;
+ garage_api = (rustPackages."unknown".garage_api."0.8.4" { inherit profileName; }).out;
+ garage_model = (rustPackages."unknown".garage_model."0.8.4" { inherit profileName; }).out;
+ garage_table = (rustPackages."unknown".garage_table."0.8.4" { inherit profileName; }).out;
+ garage_util = (rustPackages."unknown".garage_util."0.8.4" { inherit profileName; }).out;
http = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".http."0.2.9" { inherit profileName; }).out;
hyper = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hyper."0.14.27" { inherit profileName; }).out;
opentelemetry = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".opentelemetry."0.17.0" { inherit profileName; }).out;