aboutsummaryrefslogtreecommitdiff
path: root/Cargo.nix
diff options
context:
space:
mode:
authorAlex Auvolat <alex@adnab.me>2024-03-01 15:14:06 +0100
committerAlex Auvolat <alex@adnab.me>2024-03-01 16:54:39 +0100
commit6a7623e90d19c670b4fbb3ae6bc51c4c291765f3 (patch)
tree0c3ef1bf2610e05acafdffe22aa2b88fb86c5d8b /Cargo.nix
parent70b9904e9132933996a259504254e427a604aa4a (diff)
downloadgarage-rel-0.9.2.tar.gz
garage-rel-0.9.2.zip
[rel-0.9.2] Bump version to v0.9.2v0.9.2rel-0.9.2
Diffstat (limited to 'Cargo.nix')
-rw-r--r--Cargo.nix138
1 files changed, 69 insertions, 69 deletions
diff --git a/Cargo.nix b/Cargo.nix
index 059cc744..f976d2e6 100644
--- a/Cargo.nix
+++ b/Cargo.nix
@@ -34,7 +34,7 @@ args@{
ignoreLockHash,
}:
let
- nixifiedLockHash = "69c86fff0acd6c7a9a19dc6966b4cbd48e8a50c5a9fb40b3090ad71aaa5b55d0";
+ nixifiedLockHash = "3e1e0730302ee7d1f4185a13ad0086392562eb7cb962b1212801847887beaa47";
workspaceSrc = if args.workspaceSrc == null then ./. else args.workspaceSrc;
currentLockHash = builtins.hashFile "sha256" (workspaceSrc + /Cargo.lock);
lockHashIgnored = if ignoreLockHash
@@ -58,17 +58,17 @@ in
{
cargo2nixVersion = "0.11.0";
workspace = {
- garage_db = rustPackages.unknown.garage_db."0.9.1";
- garage_util = rustPackages.unknown.garage_util."0.9.1";
- garage_net = rustPackages.unknown.garage_net."0.9.1";
- garage_rpc = rustPackages.unknown.garage_rpc."0.9.1";
+ garage_db = rustPackages.unknown.garage_db."0.9.2";
+ garage_util = rustPackages.unknown.garage_util."0.9.2";
+ garage_net = rustPackages.unknown.garage_net."0.9.2";
+ garage_rpc = rustPackages.unknown.garage_rpc."0.9.2";
format_table = rustPackages.unknown.format_table."0.1.1";
- garage_table = rustPackages.unknown.garage_table."0.9.1";
- garage_block = rustPackages.unknown.garage_block."0.9.1";
- garage_model = rustPackages.unknown.garage_model."0.9.1";
- garage_api = rustPackages.unknown.garage_api."0.9.1";
- garage_web = rustPackages.unknown.garage_web."0.9.1";
- garage = rustPackages.unknown.garage."0.9.1";
+ garage_table = rustPackages.unknown.garage_table."0.9.2";
+ garage_block = rustPackages.unknown.garage_block."0.9.2";
+ garage_model = rustPackages.unknown.garage_model."0.9.2";
+ garage_api = rustPackages.unknown.garage_api."0.9.2";
+ garage_web = rustPackages.unknown.garage_web."0.9.2";
+ garage = rustPackages.unknown.garage."0.9.2";
k2v-client = rustPackages.unknown.k2v-client."0.0.4";
};
"registry+https://github.com/rust-lang/crates.io-index".addr2line."0.21.0" = overridableMkRustCrate (profileName: rec {
@@ -1871,9 +1871,9 @@ in
};
});
- "unknown".garage."0.9.1" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage."0.9.2" = overridableMkRustCrate (profileName: rec {
name = "garage";
- version = "0.9.1";
+ version = "0.9.2";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/garage");
features = builtins.concatLists [
@@ -1900,15 +1900,15 @@ in
format_table = (rustPackages."unknown".format_table."0.1.1" { inherit profileName; }).out;
futures = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures."0.3.30" { inherit profileName; }).out;
futures_util = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures-util."0.3.30" { inherit profileName; }).out;
- garage_api = (rustPackages."unknown".garage_api."0.9.1" { inherit profileName; }).out;
- garage_block = (rustPackages."unknown".garage_block."0.9.1" { inherit profileName; }).out;
- garage_db = (rustPackages."unknown".garage_db."0.9.1" { inherit profileName; }).out;
- garage_model = (rustPackages."unknown".garage_model."0.9.1" { inherit profileName; }).out;
- garage_net = (rustPackages."unknown".garage_net."0.9.1" { inherit profileName; }).out;
- garage_rpc = (rustPackages."unknown".garage_rpc."0.9.1" { inherit profileName; }).out;
- garage_table = (rustPackages."unknown".garage_table."0.9.1" { inherit profileName; }).out;
- garage_util = (rustPackages."unknown".garage_util."0.9.1" { inherit profileName; }).out;
- garage_web = (rustPackages."unknown".garage_web."0.9.1" { inherit profileName; }).out;
+ garage_api = (rustPackages."unknown".garage_api."0.9.2" { inherit profileName; }).out;
+ garage_block = (rustPackages."unknown".garage_block."0.9.2" { inherit profileName; }).out;
+ garage_db = (rustPackages."unknown".garage_db."0.9.2" { inherit profileName; }).out;
+ garage_model = (rustPackages."unknown".garage_model."0.9.2" { inherit profileName; }).out;
+ garage_net = (rustPackages."unknown".garage_net."0.9.2" { inherit profileName; }).out;
+ garage_rpc = (rustPackages."unknown".garage_rpc."0.9.2" { inherit profileName; }).out;
+ garage_table = (rustPackages."unknown".garage_table."0.9.2" { inherit profileName; }).out;
+ garage_util = (rustPackages."unknown".garage_util."0.9.2" { inherit profileName; }).out;
+ garage_web = (rustPackages."unknown".garage_web."0.9.2" { inherit profileName; }).out;
git_version = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".git-version."0.3.9" { inherit profileName; }).out;
hex = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hex."0.4.3" { inherit profileName; }).out;
sodiumoxide = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".kuska-sodiumoxide."0.2.5-0" { inherit profileName; }).out;
@@ -1946,9 +1946,9 @@ in
};
});
- "unknown".garage_api."0.9.1" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage_api."0.9.2" = overridableMkRustCrate (profileName: rec {
name = "garage_api";
- version = "0.9.1";
+ version = "0.9.2";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/api");
features = builtins.concatLists [
@@ -1968,12 +1968,12 @@ in
form_urlencoded = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".form_urlencoded."1.2.1" { inherit profileName; }).out;
futures = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures."0.3.30" { inherit profileName; }).out;
futures_util = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures-util."0.3.30" { inherit profileName; }).out;
- garage_block = (rustPackages."unknown".garage_block."0.9.1" { inherit profileName; }).out;
- garage_model = (rustPackages."unknown".garage_model."0.9.1" { inherit profileName; }).out;
- garage_net = (rustPackages."unknown".garage_net."0.9.1" { inherit profileName; }).out;
- garage_rpc = (rustPackages."unknown".garage_rpc."0.9.1" { inherit profileName; }).out;
- garage_table = (rustPackages."unknown".garage_table."0.9.1" { inherit profileName; }).out;
- garage_util = (rustPackages."unknown".garage_util."0.9.1" { inherit profileName; }).out;
+ garage_block = (rustPackages."unknown".garage_block."0.9.2" { inherit profileName; }).out;
+ garage_model = (rustPackages."unknown".garage_model."0.9.2" { inherit profileName; }).out;
+ garage_net = (rustPackages."unknown".garage_net."0.9.2" { inherit profileName; }).out;
+ garage_rpc = (rustPackages."unknown".garage_rpc."0.9.2" { inherit profileName; }).out;
+ garage_table = (rustPackages."unknown".garage_table."0.9.2" { inherit profileName; }).out;
+ garage_util = (rustPackages."unknown".garage_util."0.9.2" { inherit profileName; }).out;
hex = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hex."0.4.3" { inherit profileName; }).out;
hmac = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hmac."0.12.1" { inherit profileName; }).out;
http = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".http."1.0.0" { inherit profileName; }).out;
@@ -2004,9 +2004,9 @@ in
};
});
- "unknown".garage_block."0.9.1" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage_block."0.9.2" = overridableMkRustCrate (profileName: rec {
name = "garage_block";
- version = "0.9.1";
+ version = "0.9.2";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/block");
features = builtins.concatLists [
@@ -2020,11 +2020,11 @@ in
bytesize = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".bytesize."1.3.0" { inherit profileName; }).out;
futures = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures."0.3.30" { inherit profileName; }).out;
futures_util = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures-util."0.3.30" { inherit profileName; }).out;
- garage_db = (rustPackages."unknown".garage_db."0.9.1" { inherit profileName; }).out;
- garage_net = (rustPackages."unknown".garage_net."0.9.1" { inherit profileName; }).out;
- garage_rpc = (rustPackages."unknown".garage_rpc."0.9.1" { inherit profileName; }).out;
- garage_table = (rustPackages."unknown".garage_table."0.9.1" { inherit profileName; }).out;
- garage_util = (rustPackages."unknown".garage_util."0.9.1" { inherit profileName; }).out;
+ garage_db = (rustPackages."unknown".garage_db."0.9.2" { inherit profileName; }).out;
+ garage_net = (rustPackages."unknown".garage_net."0.9.2" { inherit profileName; }).out;
+ garage_rpc = (rustPackages."unknown".garage_rpc."0.9.2" { inherit profileName; }).out;
+ garage_table = (rustPackages."unknown".garage_table."0.9.2" { inherit profileName; }).out;
+ garage_util = (rustPackages."unknown".garage_util."0.9.2" { inherit profileName; }).out;
hex = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hex."0.4.3" { inherit profileName; }).out;
opentelemetry = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".opentelemetry."0.17.0" { inherit profileName; }).out;
rand = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".rand."0.8.5" { inherit profileName; }).out;
@@ -2037,9 +2037,9 @@ in
};
});
- "unknown".garage_db."0.9.1" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage_db."0.9.2" = overridableMkRustCrate (profileName: rec {
name = "garage_db";
- version = "0.9.1";
+ version = "0.9.2";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/db");
features = builtins.concatLists [
@@ -2064,9 +2064,9 @@ in
};
});
- "unknown".garage_model."0.9.1" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage_model."0.9.2" = overridableMkRustCrate (profileName: rec {
name = "garage_model";
- version = "0.9.1";
+ version = "0.9.2";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/model");
features = builtins.concatLists [
@@ -2085,12 +2085,12 @@ in
err_derive = (buildRustPackages."registry+https://github.com/rust-lang/crates.io-index".err-derive."0.3.1" { profileName = "__noProfile"; }).out;
futures = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures."0.3.30" { inherit profileName; }).out;
futures_util = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures-util."0.3.30" { inherit profileName; }).out;
- garage_block = (rustPackages."unknown".garage_block."0.9.1" { inherit profileName; }).out;
- garage_db = (rustPackages."unknown".garage_db."0.9.1" { inherit profileName; }).out;
- garage_net = (rustPackages."unknown".garage_net."0.9.1" { inherit profileName; }).out;
- garage_rpc = (rustPackages."unknown".garage_rpc."0.9.1" { inherit profileName; }).out;
- garage_table = (rustPackages."unknown".garage_table."0.9.1" { inherit profileName; }).out;
- garage_util = (rustPackages."unknown".garage_util."0.9.1" { inherit profileName; }).out;
+ garage_block = (rustPackages."unknown".garage_block."0.9.2" { inherit profileName; }).out;
+ garage_db = (rustPackages."unknown".garage_db."0.9.2" { inherit profileName; }).out;
+ garage_net = (rustPackages."unknown".garage_net."0.9.2" { inherit profileName; }).out;
+ garage_rpc = (rustPackages."unknown".garage_rpc."0.9.2" { inherit profileName; }).out;
+ garage_table = (rustPackages."unknown".garage_table."0.9.2" { inherit profileName; }).out;
+ garage_util = (rustPackages."unknown".garage_util."0.9.2" { inherit profileName; }).out;
hex = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hex."0.4.3" { inherit profileName; }).out;
opentelemetry = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".opentelemetry."0.17.0" { inherit profileName; }).out;
rand = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".rand."0.8.5" { inherit profileName; }).out;
@@ -2102,9 +2102,9 @@ in
};
});
- "unknown".garage_net."0.9.1" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage_net."0.9.2" = overridableMkRustCrate (profileName: rec {
name = "garage_net";
- version = "0.9.1";
+ version = "0.9.2";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/net");
features = builtins.concatLists [
@@ -2139,9 +2139,9 @@ in
};
});
- "unknown".garage_rpc."0.9.1" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage_rpc."0.9.2" = overridableMkRustCrate (profileName: rec {
name = "garage_rpc";
- version = "0.9.1";
+ version = "0.9.2";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/rpc");
features = builtins.concatLists [
@@ -2163,9 +2163,9 @@ in
format_table = (rustPackages."unknown".format_table."0.1.1" { inherit profileName; }).out;
futures = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures."0.3.30" { inherit profileName; }).out;
futures_util = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures-util."0.3.30" { inherit profileName; }).out;
- garage_db = (rustPackages."unknown".garage_db."0.9.1" { inherit profileName; }).out;
- garage_net = (rustPackages."unknown".garage_net."0.9.1" { inherit profileName; }).out;
- garage_util = (rustPackages."unknown".garage_util."0.9.1" { inherit profileName; }).out;
+ garage_db = (rustPackages."unknown".garage_db."0.9.2" { inherit profileName; }).out;
+ garage_net = (rustPackages."unknown".garage_net."0.9.2" { inherit profileName; }).out;
+ garage_util = (rustPackages."unknown".garage_util."0.9.2" { inherit profileName; }).out;
gethostname = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".gethostname."0.4.3" { inherit profileName; }).out;
hex = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hex."0.4.3" { inherit profileName; }).out;
itertools = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".itertools."0.12.1" { inherit profileName; }).out;
@@ -2187,9 +2187,9 @@ in
};
});
- "unknown".garage_table."0.9.1" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage_table."0.9.2" = overridableMkRustCrate (profileName: rec {
name = "garage_table";
- version = "0.9.1";
+ version = "0.9.2";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/table");
dependencies = {
@@ -2198,9 +2198,9 @@ in
bytes = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".bytes."1.5.0" { inherit profileName; }).out;
futures = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures."0.3.30" { inherit profileName; }).out;
futures_util = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures-util."0.3.30" { inherit profileName; }).out;
- garage_db = (rustPackages."unknown".garage_db."0.9.1" { inherit profileName; }).out;
- garage_rpc = (rustPackages."unknown".garage_rpc."0.9.1" { inherit profileName; }).out;
- garage_util = (rustPackages."unknown".garage_util."0.9.1" { inherit profileName; }).out;
+ garage_db = (rustPackages."unknown".garage_db."0.9.2" { inherit profileName; }).out;
+ garage_rpc = (rustPackages."unknown".garage_rpc."0.9.2" { inherit profileName; }).out;
+ garage_util = (rustPackages."unknown".garage_util."0.9.2" { inherit profileName; }).out;
hex = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hex."0.4.3" { inherit profileName; }).out;
hexdump = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hexdump."0.1.1" { inherit profileName; }).out;
opentelemetry = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".opentelemetry."0.17.0" { inherit profileName; }).out;
@@ -2212,9 +2212,9 @@ in
};
});
- "unknown".garage_util."0.9.1" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage_util."0.9.2" = overridableMkRustCrate (profileName: rec {
name = "garage_util";
- version = "0.9.1";
+ version = "0.9.2";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/util");
features = builtins.concatLists [
@@ -2230,8 +2230,8 @@ in
digest = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".digest."0.10.7" { inherit profileName; }).out;
err_derive = (buildRustPackages."registry+https://github.com/rust-lang/crates.io-index".err-derive."0.3.1" { profileName = "__noProfile"; }).out;
futures = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures."0.3.30" { inherit profileName; }).out;
- garage_db = (rustPackages."unknown".garage_db."0.9.1" { inherit profileName; }).out;
- garage_net = (rustPackages."unknown".garage_net."0.9.1" { inherit profileName; }).out;
+ garage_db = (rustPackages."unknown".garage_db."0.9.2" { inherit profileName; }).out;
+ garage_net = (rustPackages."unknown".garage_net."0.9.2" { inherit profileName; }).out;
hex = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hex."0.4.3" { inherit profileName; }).out;
hexdump = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hexdump."0.1.1" { inherit profileName; }).out;
http = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".http."1.0.0" { inherit profileName; }).out;
@@ -2256,18 +2256,18 @@ in
};
});
- "unknown".garage_web."0.9.1" = overridableMkRustCrate (profileName: rec {
+ "unknown".garage_web."0.9.2" = overridableMkRustCrate (profileName: rec {
name = "garage_web";
- version = "0.9.1";
+ version = "0.9.2";
registry = "unknown";
src = fetchCrateLocal (workspaceSrc + "/src/web");
dependencies = {
err_derive = (buildRustPackages."registry+https://github.com/rust-lang/crates.io-index".err-derive."0.3.1" { profileName = "__noProfile"; }).out;
futures = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".futures."0.3.30" { inherit profileName; }).out;
- garage_api = (rustPackages."unknown".garage_api."0.9.1" { inherit profileName; }).out;
- garage_model = (rustPackages."unknown".garage_model."0.9.1" { inherit profileName; }).out;
- garage_table = (rustPackages."unknown".garage_table."0.9.1" { inherit profileName; }).out;
- garage_util = (rustPackages."unknown".garage_util."0.9.1" { inherit profileName; }).out;
+ garage_api = (rustPackages."unknown".garage_api."0.9.2" { inherit profileName; }).out;
+ garage_model = (rustPackages."unknown".garage_model."0.9.2" { inherit profileName; }).out;
+ garage_table = (rustPackages."unknown".garage_table."0.9.2" { inherit profileName; }).out;
+ garage_util = (rustPackages."unknown".garage_util."0.9.2" { inherit profileName; }).out;
http = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".http."1.0.0" { inherit profileName; }).out;
http_body_util = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".http-body-util."0.1.0" { inherit profileName; }).out;
hyper = (rustPackages."registry+https://github.com/rust-lang/crates.io-index".hyper."1.1.0" { inherit profileName; }).out;