summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorAlex Auvolat <alex@adnab.me>2023-04-21 13:10:41 +0200
committerAlex Auvolat <alex@adnab.me>2023-04-21 13:10:41 +0200
commit45e12c3bcd1198bdfce3a4f7f000ef4177067a5c (patch)
tree603808716ac2fb6b6b639acdcefe6e76fc48e3b6 /Cargo.toml
parenta11ed03031cb59b412950d62960fc27cf919e2bf (diff)
downloaddf-consul-45e12c3bcd1198bdfce3a4f7f000ef4177067a5c.tar.gz
df-consul-45e12c3bcd1198bdfce3a4f7f000ef4177067a5c.zip
add kv_get_prefixv0.3.4
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml3
1 files changed, 2 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 3f967b4..99c4aa0 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -2,7 +2,7 @@
name = "df-consul"
description = "Deuxfleurs' async Rust bindings for (a subset of) the Consul HTTP API"
authors = [ "Alex Auvolat <alex@adnab.me>" ]
-version = "0.3.3"
+version = "0.3.4"
edition = "2021"
license = "MIT"
repository = "https://git.deuxfleurs.fr/Deuxfleurs/df-consul"
@@ -14,6 +14,7 @@ anyhow = "1.0.66"
serde = { version = "1.0.149", features = ["derive"] }
log = "0.4"
bytes = "1"
+base64 = "0.13"
reqwest = { version = "0.11", default-features = false, features = ["json", "rustls-tls-manual-roots" ] }
tokio = { version = "1.23", default-features = false, features = [ "macros" ] }
futures = "0.3.25"