summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorAlex Auvolat <alex@adnab.me>2022-12-07 14:19:26 +0100
committerAlex Auvolat <alex@adnab.me>2022-12-07 14:19:26 +0100
commit0a641cae9656f22cb7be715a4684f43ca52a76bb (patch)
treea04085f6b986b3ebce571bdc7aa6aa417b87ca12 /Cargo.toml
downloaddf-consul-0a641cae9656f22cb7be715a4684f43ca52a76bb.tar.gz
df-consul-0a641cae9656f22cb7be715a4684f43ca52a76bb.zip
First version of df-consul
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml15
1 files changed, 15 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..3716846
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,15 @@
+[package]
+name = "df-consul"
+description = "Deuxfleurs' async Rust bindings for (a subset of) the Consul HTTP API"
+authors = [ "Alex Auvolat <alex@adnab.me>" ]
+version = "0.1.0"
+edition = "2021"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+anyhow = "1.0.66"
+serde = { version = "1.0.149", features = ["derive"] }
+log = "0.4"
+bytes = "1"
+reqwest = { version = "0.11", default-features = false, features = ["json", "rustls-tls-manual-roots" ] }