aboutsummaryrefslogtreecommitdiff
path: root/aero-dav/fuzz/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'aero-dav/fuzz/Cargo.toml')
-rw-r--r--aero-dav/fuzz/Cargo.toml24
1 files changed, 24 insertions, 0 deletions
diff --git a/aero-dav/fuzz/Cargo.toml b/aero-dav/fuzz/Cargo.toml
new file mode 100644
index 0000000..a450853
--- /dev/null
+++ b/aero-dav/fuzz/Cargo.toml
@@ -0,0 +1,24 @@
+[package]
+name = "aerogramme-fuzz"
+version = "0.0.0"
+publish = false
+edition = "2021"
+
+[package.metadata]
+cargo-fuzz = true
+
+[dependencies]
+arbitrary = { version = "1", optional = true, features = ["derive"] }
+libfuzzer-sys = { version = "0.4", features = ["arbitrary-derive"] }
+tokio = { version = "1.18", default-features = false, features = ["rt", "rt-multi-thread", "io-util", "net", "time", "macros", "sync", "signal", "fs"] }
+quick-xml = { version = "0.31", features = ["async-tokio"] }
+
+[dependencies.aero-dav]
+path = ".."
+
+[[bin]]
+name = "dav"
+path = "fuzz_targets/dav.rs"
+test = false
+doc = false
+bench = false