aboutsummaryrefslogtreecommitdiff
path: root/aerogramme/Cargo.toml
diff options
context:
space:
mode:
authorQuentin Dufour <quentin@deuxfleurs.fr>2024-05-29 10:14:51 +0200
committerQuentin Dufour <quentin@deuxfleurs.fr>2024-05-29 10:14:51 +0200
commitb9ce5886033677f6c65a4b873e17574fdb8df31d (patch)
tree9ed1d721361027d7d6fef0ecad65d7e1b74a7ddb /aerogramme/Cargo.toml
parent0dcf69f180f5a7b71b6ad2ac67e4cdd81e5154f1 (diff)
parent5954de6efbb040b8b47daf0c7663a60f3db1da6e (diff)
downloadaerogramme-b9ce5886033677f6c65a4b873e17574fdb8df31d.tar.gz
aerogramme-b9ce5886033677f6c65a4b873e17574fdb8df31d.zip
Merge branch 'caldav'
Diffstat (limited to 'aerogramme/Cargo.toml')
-rw-r--r--aerogramme/Cargo.toml32
1 files changed, 32 insertions, 0 deletions
diff --git a/aerogramme/Cargo.toml b/aerogramme/Cargo.toml
new file mode 100644
index 0000000..77f3584
--- /dev/null
+++ b/aerogramme/Cargo.toml
@@ -0,0 +1,32 @@
+[package]
+name = "aerogramme"
+version = "0.3.0"
+authors = ["Alex Auvolat <alex@adnab.me>", "Quentin Dufour <quentin@dufour.io>"]
+edition = "2021"
+license = "EUPL-1.2"
+description = "A robust email server"
+
+[dependencies]
+aero-user.workspace = true
+aero-proto.workspace = true
+
+anyhow.workspace = true
+backtrace.workspace = true
+futures.workspace = true
+tokio.workspace = true
+log.workspace = true
+nix.workspace = true
+clap.workspace = true
+tracing.workspace = true
+tracing-subscriber.workspace = true
+rpassword.workspace = true
+
+[dev-dependencies]
+reqwest.workspace = true
+aero-dav.workspace = true
+quick-xml.workspace = true
+
+[[test]]
+name = "behavior"
+path = "tests/behavior.rs"
+harness = false