aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorAlex Auvolat <alex@adnab.me>2022-05-18 12:24:37 +0200
committerAlex Auvolat <alex@adnab.me>2022-05-18 12:26:50 +0200
commit7a3ce9f81963cc374271272bfe4e0e204e9b7012 (patch)
tree369a1c390d5aeb5f3ce2515b677affca366cc328 /Cargo.toml
downloadaerogramme-7a3ce9f81963cc374271272bfe4e0e204e9b7012.tar.gz
aerogramme-7a3ce9f81963cc374271272bfe4e0e204e9b7012.zip
Skeleton for some stuff
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml24
1 files changed, 24 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..c6ceb8a
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,24 @@
+[package]
+name = "mailrage"
+version = "0.0.1"
+authors = ["Alex Auvolat <alex@adnab.me>"]
+edition = "2021"
+license = "AGPL-3.0"
+description = "Encrypted mail storage over Garage"
+
+[dependencies]
+anyhow = "1.0.28"
+hex = "0.4"
+im = "15"
+rusoto_core = "0.48.0"
+rusoto_credential = "0.48.0"
+rusoto_s3 = "0.48"
+rusoto_signature = "0.48.0"
+serde = "1.0.137"
+rand = "0.8.5"
+rmp-serde = "0.15"
+sodiumoxide = "0.2"
+tokio = "1.17.0"
+zstd = { version = "0.9", default-features = false }
+
+k2v-client = { git = "https://git.deuxfleurs.fr/trinity-1686a/garage.git", branch = "k2v-client" }