aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorAlex Auvolat <alex@adnab.me>2022-05-31 17:07:34 +0200
committerAlex Auvolat <alex@adnab.me>2022-05-31 17:07:34 +0200
commit553a15a82a700792986b23cb89e2a8ec070cc27d (patch)
tree8ea039322b39064fa8c66d9647f84b79f64f1921 /Cargo.toml
parent01d82c14ca61e7c4de1e72c5f94456610464c064 (diff)
downloadaerogramme-553a15a82a700792986b23cb89e2a8ec070cc27d.tar.gz
aerogramme-553a15a82a700792986b23cb89e2a8ec070cc27d.zip
Implementn basic LMTP server
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml6
1 files changed, 5 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 16d0b52..00acdca 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -12,7 +12,9 @@ argon2 = "0.3"
async-trait = "0.1"
base64 = "0.13"
clap = { version = "3.1.18", features = ["derive", "env"] }
+duplexify = "1.1.0"
hex = "0.4"
+futures = "0.3"
im = "15"
itertools = "0.10"
lazy_static = "1.4"
@@ -28,10 +30,12 @@ rand = "0.8.5"
rmp-serde = "0.15"
rpassword = "6.0"
sodiumoxide = "0.2"
-tokio = "1.17.0"
+tokio = { version = "1.18", default-features = false, features = ["rt", "rt-multi-thread", "io-util", "net", "time", "macros", "sync", "signal", "fs"] }
+tokio-util = { version = "0.7", features = [ "compat" ] }
toml = "0.5"
zstd = { version = "0.9", default-features = false }
+smtp-message = { git = "http://github.com/Alexis211/kannader", branch = "feature/lmtp" }
smtp-server = { git = "http://github.com/Alexis211/kannader", branch = "feature/lmtp" }
k2v-client = { git = "https://git.deuxfleurs.fr/Deuxfleurs/garage.git", branch = "improve-k2v-client" }