aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorQuentin Dufour <quentin@deuxfleurs.fr>2024-02-23 17:01:51 +0100
committerQuentin Dufour <quentin@deuxfleurs.fr>2024-02-23 17:01:51 +0100
commit02a8537556236437d905cefe8aa2c5d0a96f129a (patch)
tree823c209287b2bd5373bf941ea5362e7f97eb94f6 /Cargo.toml
parenta579382042e0e1af95a00e97647a2cc3794fb108 (diff)
downloadaerogramme-02a8537556236437d905cefe8aa2c5d0a96f129a.tar.gz
aerogramme-02a8537556236437d905cefe8aa2c5d0a96f129a.zip
Replace with a single AWS HTTP client
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml7
1 files changed, 5 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index aad2ac6..48d1db4 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -49,6 +49,7 @@ rustls = "0.22"
rustls-pemfile = "2.0"
tokio-rustls = "0.25"
hyper-rustls = { version = "0.24", features = ["http2"] }
+hyper-util = { version = "0.1", features = ["client"] }
rpassword = "7.0"
# login
@@ -56,8 +57,10 @@ ldap3 = { version = "0.10", default-features = false, features = ["tls-rustls"]
# storage
k2v-client = { git = "https://git.deuxfleurs.fr/Deuxfleurs/garage.git", tag = "v0.9.1" }
-aws-config = { version = "1.1.1", features = ["behavior-version-latest"] }
-aws-sdk-s3 = "1.9.0"
+aws-config = { version = "1", features = ["behavior-version-latest"] }
+aws-sdk-s3 = "1"
+aws-smithy-runtime = "1"
+aws-smithy-runtime-api = "1"
# email protocols
eml-codec = "0.1.2"