summaryrefslogtreecommitdiff
path: root/nixos/sway.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/sway.nix')
-rw-r--r--nixos/sway.nix32
1 files changed, 32 insertions, 0 deletions
diff --git a/nixos/sway.nix b/nixos/sway.nix
new file mode 100644
index 0000000..73050f5
--- /dev/null
+++ b/nixos/sway.nix
@@ -0,0 +1,32 @@
+{ config, lib, pkgs, modulesPath, ... }:
+{
+ imports = [
+ ./wmonly.nix
+ ];
+
+ programs.sway = {
+ enable = true;
+ #package = pkgs.swayfx;
+ wrapperFeatures.gtk = true;
+ wrapperFeatures.base = true;
+ extraPackages = with pkgs; [
+ glib
+ ];
+ };
+
+ security.pam.services.swaylock = {};
+
+ environment.systemPackages = with pkgs; [
+ swaybg
+ bemenu
+ swayimg
+
+ xdg-desktop-portal-wlr
+ waybar
+ alacritty
+ swaylock
+ wdisplays
+ grim
+ cage
+ ];
+}