aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml19
1 files changed, 19 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..1547899
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,19 @@
+[package]
+name = "tricot"
+version = "0.1.0"
+edition = "2018"
+authors = ["Alex Auvolat <alex@adnab.me>"]
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+anyhow = "1.0.28"
+envy = "0.4"
+futures = "0.3.5"
+log = "0.4"
+pretty_env_logger = "0.4"
+regex = "1"
+reqwest = { version = "0.11", features = ["json"] }
+serde = { version = "1.0.107", features = ["derive"] }
+serde_json = "1.0.53"
+tokio = { version = "1.0", default-features = false, features = ["rt", "rt-multi-thread", "io-util", "net", "time", "macros", "sync", "signal", "fs"] }