aboutsummaryrefslogtreecommitdiff
path: root/secretmgr/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'secretmgr/shell.nix')
-rw-r--r--secretmgr/shell.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/secretmgr/shell.nix b/secretmgr/shell.nix
new file mode 100644
index 0000000..c9b8053
--- /dev/null
+++ b/secretmgr/shell.nix
@@ -0,0 +1,15 @@
+{
+ pkgs ? import <nixpkgs> {}
+}:
+
+with pkgs; mkShell {
+ nativeBuildInputs = [
+ nomad
+ docker-compose
+ python39Packages.pip
+ python39Packages.ldap
+ python39Packages.consul
+ python39Packages.passlib
+ ];
+}
+