aboutsummaryrefslogtreecommitdiff
path: root/node/caribou.nix
diff options
context:
space:
mode:
Diffstat (limited to 'node/caribou.nix')
-rw-r--r--node/caribou.nix39
1 files changed, 3 insertions, 36 deletions
diff --git a/node/caribou.nix b/node/caribou.nix
index 77fc35b..dc5e917 100644
--- a/node/caribou.nix
+++ b/node/caribou.nix
@@ -8,7 +8,7 @@
boot.loader.timeout = 20;
boot.loader.efi.canTouchEfiVariables = true;
- networking.hostName = "caribou"; # Define your hostname.
+ networking.hostName = "caribou";
networking.interfaces.eno1.useDHCP = false;
networking.interfaces.eno1.ipv4.addresses = [
@@ -29,43 +29,10 @@
listenPort = 33723;
};
- # OR use USB modem plugged in here
- #networking.interfaces.enp0s20u1.useDHCP = true;
+ # Enable netdata monitoring
+ services.netdata.enable = true;
# Activate as Nomad and Consul server node
services.nomad.settings.server.enabled = true;
services.consul.extraConfig.server = true;
-
- # Enable netdata monitoring
- services.netdata.enable = true;
-
- # ----
-
- # Enable nix-serve
- services.nix-serve = {
- enable = true;
- secretKeyFile = "/var/cache-priv-key.pem";
- };
-
- # Configure a Nginx web server to serve NixOS cache
- services.nginx = {
- enable = true;
- virtualHosts = {
- "binarycache.home.adnab.me" = {
- serverAliases = [ "binarycache" ];
- listen = [ {
- addr = "0.0.0.0";
- port = 7980;
- } ];
- locations."/".extraConfig = ''
- proxy_pass http://localhost:${toString config.services.nix-serve.port};
- proxy_set_header Host $host;
- proxy_set_header X-Real-IP $remote_addr;
- proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
- '';
- };
- };
- };
-
- networking.firewall.allowedTCPPorts = [ 7980 ];
}