aboutsummaryrefslogtreecommitdiff
path: root/node/caribou.nix
diff options
context:
space:
mode:
Diffstat (limited to 'node/caribou.nix')
-rw-r--r--node/caribou.nix6
1 files changed, 5 insertions, 1 deletions
diff --git a/node/caribou.nix b/node/caribou.nix
index e354754..366251a 100644
--- a/node/caribou.nix
+++ b/node/caribou.nix
@@ -47,6 +47,10 @@
virtualHosts = {
"binarycache.home.adnab.me" = {
serverAliases = [ "binarycache" ];
+ listen = [ {
+ addr = "0.0.0.0";
+ port = 7980;
+ } ];
locations."/".extraConfig = ''
proxy_pass http://localhost:${toString config.services.nix-serve.port};
proxy_set_header Host $host;
@@ -57,5 +61,5 @@
};
};
- networking.firewall.allowedTCPPorts = [ 80 ];
+ networking.firewall.allowedTCPPorts = [ 7980 ];
}