aboutsummaryrefslogtreecommitdiff
path: root/node/caribou.nix
diff options
context:
space:
mode:
Diffstat (limited to 'node/caribou.nix')
-rw-r--r--node/caribou.nix38
1 files changed, 0 insertions, 38 deletions
diff --git a/node/caribou.nix b/node/caribou.nix
deleted file mode 100644
index dc5e917..0000000
--- a/node/caribou.nix
+++ /dev/null
@@ -1,38 +0,0 @@
-# Configuration file local to this node
-
-{ config, pkgs, ... }:
-
-{
- # Use the systemd-boot EFI boot loader.
- boot.loader.systemd-boot.enable = true;
- boot.loader.timeout = 20;
- boot.loader.efi.canTouchEfiVariables = true;
-
- networking.hostName = "caribou";
-
- networking.interfaces.eno1.useDHCP = false;
- networking.interfaces.eno1.ipv4.addresses = [
- {
- address = "192.168.1.23";
- prefixLength = 24;
- }
- ];
- networking.interfaces.eno1.ipv6.addresses = [
- {
- address = "2a01:e0a:c:a720::23";
- prefixLength = 64;
- }
- ];
-
- networking.wireguard.interfaces.wg0 = {
- ips = [ "10.42.0.23/16" ];
- listenPort = 33723;
- };
-
- # Enable netdata monitoring
- services.netdata.enable = true;
-
- # Activate as Nomad and Consul server node
- services.nomad.settings.server.enabled = true;
- services.consul.extraConfig.server = true;
-}