aboutsummaryrefslogtreecommitdiff
path: root/node/carcajou.nix
diff options
context:
space:
mode:
Diffstat (limited to 'node/carcajou.nix')
-rw-r--r--node/carcajou.nix29
1 files changed, 23 insertions, 6 deletions
diff --git a/node/carcajou.nix b/node/carcajou.nix
index 15e4395..0d12899 100644
--- a/node/carcajou.nix
+++ b/node/carcajou.nix
@@ -3,6 +3,11 @@
{ config, pkgs, ... }:
{
+ # Use the systemd-boot EFI boot loader.
+ boot.loader.systemd-boot.enable = true;
+ boot.loader.timeout = 20;
+ boot.loader.efi.canTouchEfiVariables = true;
+
networking.hostName = "carcajou";
networking.interfaces.eno1.useDHCP = false;
@@ -12,15 +17,27 @@
prefixLength = 24;
}
];
- # networking.interfaces.eno1.ipv6.addresses = [
- # {
- # address = "2a01:e0a:c:a720::22";
- # prefixLength = 64;
- # }
- # ];
+ networking.defaultGateway = {
+ address = "192.168.1.254";
+ interface = "eno1";
+ };
networking.wireguard.interfaces.wg0 = {
ips = [ "10.42.0.22/16" ];
listenPort = 33722;
};
+
+ # Enable netdata monitoring
+ services.netdata.enable = true;
+
+ # ----
+
+ nix = {
+ binaryCaches = [
+ "http://binarycache.home.adnab.me"
+ ];
+ binaryCachePublicKeys = [
+ "binarycache.home.adnab.me:ErR6pMnewf9oVyZJd5uC2nI4EZF49c7Mh86eDZWYZaw="
+ ];
+ };
}