aboutsummaryrefslogtreecommitdiff
path: root/node/carcajou.nix
diff options
context:
space:
mode:
Diffstat (limited to 'node/carcajou.nix')
-rw-r--r--node/carcajou.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/node/carcajou.nix b/node/carcajou.nix
new file mode 100644
index 0000000..ae6b488
--- /dev/null
+++ b/node/carcajou.nix
@@ -0,0 +1,24 @@
+# Configuration file local to this node
+
+{ config, pkgs, ... }:
+
+{
+ networking.hostName = "carcajou"; # Define your hostname.
+
+ networking.interfaces.eno1.useDHCP = false;
+ networking.interfaces.eno1.ipv4.addresses = [
+ {
+ address = "192.168.1.22";
+ prefixLength = 24;
+ }
+ ];
+
+ nix = {
+ binaryCaches = [
+ "http://binarycache.home.adnab.me"
+ ];
+ binaryCachePublicKeys = [
+ "binarycache.home.adnab.me:ErR6pMnewf9oVyZJd5uC2nI4EZF49c7Mh86eDZWYZaw="
+ ];
+ };
+}