aboutsummaryrefslogtreecommitdiff
path: root/nix/wgautomesh.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/wgautomesh.nix')
-rw-r--r--nix/wgautomesh.nix7
1 files changed, 6 insertions, 1 deletions
diff --git a/nix/wgautomesh.nix b/nix/wgautomesh.nix
index e46ad75..5a1480c 100644
--- a/nix/wgautomesh.nix
+++ b/nix/wgautomesh.nix
@@ -14,6 +14,11 @@ in
{
options.services.wgautomesh = {
enable = mkEnableOption "wgautomesh";
+ logLevel = mkOption {
+ type = types.str;
+ default = "info";
+ description = "wgautomesh log level (trace/debug/info/warn/error)";
+ };
interface = mkOption {
type = types.str;
description = "Wireguard interface to manage";
@@ -97,7 +102,7 @@ in
enable = true;
path = [ pkgs.wireguard-tools ];
environment = {
- RUST_LOG = "wgautomesh=info";
+ RUST_LOG = "wgautomesh=${cfg.logLevel}";
};
description = "wgautomesh";
serviceConfig = {