aboutsummaryrefslogtreecommitdiff
path: root/nix/deuxfleurs.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/deuxfleurs.nix')
-rw-r--r--nix/deuxfleurs.nix7
1 files changed, 6 insertions, 1 deletions
diff --git a/nix/deuxfleurs.nix b/nix/deuxfleurs.nix
index 0f5c185..9ef2b2a 100644
--- a/nix/deuxfleurs.nix
+++ b/nix/deuxfleurs.nix
@@ -117,6 +117,11 @@ in
type = port;
default = 33799;
};
+ wgautomeshPort = mkOption {
+ description = "Gossip port for wgautomesh";
+ type = port;
+ default = 1666;
+ };
};
imports = [
@@ -245,7 +250,7 @@ in
services.wgautomesh = {
enable = true;
interface = "wg0";
- gossipPort = 1666;
+ gossipPort = cfg.wgautomeshPort;
gossipSecretFile = "/var/lib/wgautomesh/gossip_secret";
persistFile = "/var/lib/wgautomesh/state";
upnpForwardPublicPort =