aboutsummaryrefslogtreecommitdiff
path: root/nix/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/configuration.nix')
-rw-r--r--nix/configuration.nix7
1 files changed, 6 insertions, 1 deletions
diff --git a/nix/configuration.nix b/nix/configuration.nix
index 17bb9b8..800d36d 100644
--- a/nix/configuration.nix
+++ b/nix/configuration.nix
@@ -64,7 +64,6 @@ SystemMaxUse=1G
links2
git
rclone
- docker
docker-compose
wireguard-tools
#qemu
@@ -81,6 +80,12 @@ SystemMaxUse=1G
services.openssh.enable = true;
services.openssh.passwordAuthentication = false;
+ virtualisation.docker = {
+ enable = true;
+ extraOptions = "--config-file=${pkgs.writeText "daemon.json" (builtins.toJSON {
+ dns = [ "172.17.0.1" "8.8.8.8" "8.8.4.4" ];
+ })}";
+ };
# This value determines the NixOS release from which the default
# settings for stateful data, like file locations and database versions