aboutsummaryrefslogtreecommitdiff
path: root/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'configuration.nix')
-rw-r--r--configuration.nix47
1 files changed, 6 insertions, 41 deletions
diff --git a/configuration.nix b/configuration.nix
index 65fa44b..dbdbd52 100644
--- a/configuration.nix
+++ b/configuration.nix
@@ -15,20 +15,6 @@ in
./node.nix
];
- # Use the systemd-boot EFI boot loader.
- boot.loader.systemd-boot.enable = true;
- boot.loader.timeout = 20;
- boot.loader.efi.canTouchEfiVariables = true;
-
- nix = {
- binaryCaches = [
- "http://binarycache.home.adnab.me"
- ];
- binaryCachePublicKeys = [
- "binarycache.home.adnab.me:ErR6pMnewf9oVyZJd5uC2nI4EZF49c7Mh86eDZWYZaw="
- ];
- };
-
# The global useDHCP flag is deprecated, therefore explicitly set to false here.
# Per-interface useDHCP will be mandatory in the future, so this generated config
# replicates the default behaviour.
@@ -36,12 +22,7 @@ in
# networking.wireless.enable = true; # Enables wireless support via wpa_supplicant.
# Networking configuration (static IPs for each node is defined in node/*.nix)
-
networking.nameservers = [ "9.9.9.9" ];
- networking.defaultGateway = {
- address = "192.168.1.254";
- interface = "eno1";
- };
# Wireguard VPN configuration
networking.wireguard.interfaces.wg0 = {
@@ -59,6 +40,12 @@ in
endpoint = "77.141.67.109:42136";
persistentKeepalive = 10;
}
+ { # Robinson
+ publicKey = "ETaZFil3mFXlJ0LaJZyWqJVLV2IZUF5PB/8M7WbQSTg=";
+ allowedIPs = [ "10.42.0.42/32" ];
+ endpoint = "77.141.67.109:33742";
+ persistentKeepalive = 10;
+ }
{ # Shiki
publicKey = "QUiUNMk70TEQ75Ut7Uqikr5uGVSXmx8EGNkGM6tANlg=";
allowedIPs = [ "10.42.0.206/32" ];
@@ -214,33 +201,12 @@ in
# List services that you want to enable:
- # Enable Yggdrasil networking
- services.yggdrasil.enable = true;
- services.yggdrasil.persistentKeys = true;
- services.yggdrasil.config = {
- Listen = [
- "tcp://0.0.0.0:54312"
- ];
- Peers = [
- "tcp://37.187.118.206:53102"
- "tcp://192.168.1.21:54312"
- "tcp://192.168.1.22:54312"
- "tcp://192.168.1.23:54312"
- ];
- MulticastInterfaces = [
- "eno1"
- ];
- };
-
# Enable network time
services.ntp.enable = true;
# Enable the OpenSSH daemon.
services.openssh.enable = true;
- # Enable netdata monitoring
- services.netdata.enable = true;
-
# Enable Hashicorp Consul & Nomad
services.consul.enable = true;
services.consul.extraConfig =
@@ -298,7 +264,6 @@ in
4646 4647 4648 # Nomad
8500 8300 8301 8302 # Consul
19999 # Netdata
- 54312 # Yggdrasil
];
networking.firewall.allowedUDPPorts = [
4648 # Nomad