aboutsummaryrefslogtreecommitdiff
path: root/cluster/staging/node/caribou.nix
diff options
context:
space:
mode:
Diffstat (limited to 'cluster/staging/node/caribou.nix')
-rw-r--r--cluster/staging/node/caribou.nix15
1 files changed, 8 insertions, 7 deletions
diff --git a/cluster/staging/node/caribou.nix b/cluster/staging/node/caribou.nix
index 3be3cdc..7b785ef 100644
--- a/cluster/staging/node/caribou.nix
+++ b/cluster/staging/node/caribou.nix
@@ -3,6 +3,11 @@
{ config, pkgs, ... }:
{
+ imports =
+ [
+ ./remote-unlock.nix
+ ];
+
# Use the systemd-boot EFI boot loader.
boot.loader.systemd-boot.enable = true;
boot.loader.timeout = 20;
@@ -10,13 +15,9 @@
networking.hostName = "caribou";
- networking.interfaces.eno1.useDHCP = false;
- networking.interfaces.eno1.ipv4.addresses = [
- {
- address = "192.168.1.23";
- prefixLength = 24;
- }
- ];
+ deuxfleurs.network_interface = "eno1";
+ deuxfleurs.lan_ip = "192.168.1.23";
+
networking.interfaces.eno1.ipv6.addresses = [
{
address = "2a01:e0a:c:a720::23";