aboutsummaryrefslogtreecommitdiff
path: root/cluster/prod/site/orion.nix
diff options
context:
space:
mode:
Diffstat (limited to 'cluster/prod/site/orion.nix')
-rw-r--r--cluster/prod/site/orion.nix17
1 files changed, 9 insertions, 8 deletions
diff --git a/cluster/prod/site/orion.nix b/cluster/prod/site/orion.nix
index fb4ba22..5f6c33e 100644
--- a/cluster/prod/site/orion.nix
+++ b/cluster/prod/site/orion.nix
@@ -1,14 +1,15 @@
{ config, pkgs, ... }:
{
- deuxfleurs.site_name = "orion";
- deuxfleurs.lan_default_gateway = "192.168.1.254";
- deuxfleurs.ipv6_default_gateway = "2a01:e0a:28f:5e60::1";
- deuxfleurs.lan_ip_prefix_length = 24;
- deuxfleurs.ipv6_prefix_length = 64;
- deuxfleurs.nameservers = [ "192.168.1.254" ];
- deuxfleurs.cname_target = "orion.site.deuxfleurs.fr.";
- deuxfleurs.public_ipv4 = "82.66.80.201";
+ deuxfleurs.siteName = "orion";
+ deuxfleurs.staticIPv4.defaultGateway = "192.168.1.254";
+ # Setting an IPv6 default gateway will disable RA for now.
+ # Adding this for now as Orion has the mail servers and we are
+ # not yet confident we can disable this without getting ourselves
+ # banned by sending from unwanted IPs (although it should be ok).
+ deuxfleurs.staticIPv6.defaultGateway = "2a01:e0a:28f:5e60::1";
+ deuxfleurs.cnameTarget = "orion.site.deuxfleurs.fr.";
+ deuxfleurs.publicIPv4 = "82.66.80.201";
networking.firewall.allowedTCPPorts = [ 80 443 ];
}