aboutsummaryrefslogtreecommitdiff
path: root/cluster/prod/cluster.nix
diff options
context:
space:
mode:
Diffstat (limited to 'cluster/prod/cluster.nix')
-rw-r--r--cluster/prod/cluster.nix101
1 files changed, 45 insertions, 56 deletions
diff --git a/cluster/prod/cluster.nix b/cluster/prod/cluster.nix
index 44c376e..ea3bdec 100644
--- a/cluster/prod/cluster.nix
+++ b/cluster/prod/cluster.nix
@@ -1,84 +1,73 @@
{ config, pkgs, ... } @ args:
{
- deuxfleurs.cluster_name = "prod";
+ deuxfleurs.clusterName = "prod";
# The IP range to use for the Wireguard overlay of this cluster
- deuxfleurs.cluster_prefix = "10.83.0.0";
- deuxfleurs.cluster_prefix_length = 16;
+ deuxfleurs.clusterPrefix = "10.83.0.0/16";
- deuxfleurs.cluster_nodes = [
- {
- hostname = "concombre";
- site_name = "neptune";
+ deuxfleurs.clusterNodes = {
+ "concombre" = {
+ siteName = "neptune";
publicKey = "VvXT0fPDfWsHxumZqVShpS33dJQAdpJ1E79ZbCBJP34=";
- IP = "10.83.1.1";
+ address = "10.83.1.1";
endpoint = "77.207.15.215:33731";
- }
- {
- hostname = "courgette";
- site_name = "neptune";
+ };
+ "courgette" = {
+ siteName = "neptune";
publicKey = "goTkBJGmzrGDOAjUcdH9G0JekipqSMoaYQdB6IHnzi0=";
- IP = "10.83.1.2";
+ address = "10.83.1.2";
endpoint = "77.207.15.215:33732";
- }
- {
- hostname = "celeri";
- site_name = "neptune";
+ };
+ "celeri" = {
+ siteName = "neptune";
publicKey = "oZDAb8LoLW87ktUHyFFec0VaIar97bqq47mGbdVqJ0U=";
- IP = "10.83.1.3";
+ address = "10.83.1.3";
endpoint = "77.207.15.215:33733";
- }
- {
- hostname = "dahlia";
- site_name = "orion";
+ };
+ "dahlia" = {
+ siteName = "orion";
publicKey = "EtRoWBYCdjqgXX0L+uWLg8KxNfIK8k9OTh30tL19bXU=";
- IP = "10.83.2.1";
+ address = "10.83.2.1";
endpoint = "82.66.80.201:33731";
- }
- {
- hostname = "diplotaxis";
- site_name = "orion";
+ };
+ "diplotaxis" = {
+ siteName = "orion";
publicKey = "HbLC938mysadMSOxWgq8+qrv+dBKzPP/43OMJp/3phA=";
- IP = "10.83.2.2";
+ address = "10.83.2.2";
endpoint = "82.66.80.201:33732";
- }
- {
- hostname = "doradille";
- site_name = "orion";
+ };
+ "doradille" = {
+ siteName = "orion";
publicKey = "e1C8jgTj9eD20ywG08G1FQZ+Js3wMK/msDUE1wO3l1Y=";
- IP = "10.83.2.3";
+ address = "10.83.2.3";
endpoint = "82.66.80.201:33733";
- }
- {
- hostname = "df-ykl";
- site_name = "bespin";
+ };
+ "df-ykl" = {
+ siteName = "bespin";
publicKey = "bIjxey/VhBgVrLa0FxN/KISOt2XFmQeSh1MPivUq9gg=";
- IP = "10.83.3.1";
+ address = "10.83.3.1";
endpoint = "109.136.55.235:33731";
- }
- {
- hostname = "df-ymf";
- site_name = "bespin";
+ };
+ "df-ymf" = {
+ siteName = "bespin";
publicKey = "pUIKv8UBl586O7DBrHBsb9BgNU7WlYQ2r2RSNkD+JAQ=";
- IP = "10.83.3.2";
+ address = "10.83.3.2";
endpoint = "109.136.55.235:33732";
- }
- {
- hostname = "df-ymk";
- site_name = "bespin";
+ };
+ "df-ymk" = {
+ siteName = "bespin";
publicKey = "VBmpo15iIJP7250NAsF+ryhZc3j+8TZFnE1Djvn5TXI=";
- IP = "10.83.3.3";
+ address = "10.83.3.3";
endpoint = "109.136.55.235:33733";
- }
- {
- hostname = "abricot";
- site_name = "scorpio";
+ };
+ "abricot" = {
+ siteName = "scorpio";
publicKey = "Sm9cmNZ/BfWVPFflMO+fuyiera4r203b/dKhHTQmBFg=";
- IP = "10.83.4.1";
+ address = "10.83.4.1";
endpoint = "82.65.41.110:33741";
- }
- ];
+ };
+ };
# Bootstrap IPs for Consul cluster,
# these are IPs on the Wireguard overlay
@@ -88,7 +77,7 @@
"10.83.3.1" # df-ykl
];
- deuxfleurs.admin_accounts = {
+ deuxfleurs.adminAccounts = {
lx = [
# Keys for accessing nodes from outside
"ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIJpaBZdYxHqMxhv2RExAOa7nkKhPBOHupMP3mYaZ73w9 lx@lindy"