aboutsummaryrefslogtreecommitdiff
path: root/cluster/prod/app/cryptpad/build/deuxfleurs.nix
diff options
context:
space:
mode:
Diffstat (limited to 'cluster/prod/app/cryptpad/build/deuxfleurs.nix')
-rw-r--r--cluster/prod/app/cryptpad/build/deuxfleurs.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/cluster/prod/app/cryptpad/build/deuxfleurs.nix b/cluster/prod/app/cryptpad/build/deuxfleurs.nix
new file mode 100644
index 0000000..5cb8b8e
--- /dev/null
+++ b/cluster/prod/app/cryptpad/build/deuxfleurs.nix
@@ -0,0 +1,12 @@
+{ name ? "deuxfleurs/cryptpad"
+, tag ? "nix-latest"
+}: let
+ sources = import ./nix/sources.nix;
+ pkgs = import sources.nixpkgs {};
+in rec {
+ cryptpad = pkgs.callPackage ./default.nix {};
+ docker = pkgs.callPackage ./docker.nix {
+ inherit name tag;
+ inherit cryptpad;
+ };
+}