aboutsummaryrefslogtreecommitdiff
path: root/secretmgr/shell.nix
diff options
context:
space:
mode:
authorAlex Auvolat <alex@adnab.me>2022-08-24 15:48:18 +0200
committerAlex Auvolat <alex@adnab.me>2022-08-24 15:48:18 +0200
commit41128f4c36f79def480b8cb866205296d703f247 (patch)
tree1ffaf8cd67d528b0eb9ee7943119157e3efdcfb2 /secretmgr/shell.nix
parent981294e3d7a180a3c08f8173dc652b73b6e2bd07 (diff)
downloadnixcfg-41128f4c36f79def480b8cb866205296d703f247.tar.gz
nixcfg-41128f4c36f79def480b8cb866205296d703f247.zip
Clone core module in staging and prod, move bad stuff to experimental
Diffstat (limited to 'secretmgr/shell.nix')
-rw-r--r--secretmgr/shell.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/secretmgr/shell.nix b/secretmgr/shell.nix
new file mode 100644
index 0000000..c9b8053
--- /dev/null
+++ b/secretmgr/shell.nix
@@ -0,0 +1,15 @@
+{
+ pkgs ? import <nixpkgs> {}
+}:
+
+with pkgs; mkShell {
+ nativeBuildInputs = [
+ nomad
+ docker-compose
+ python39Packages.pip
+ python39Packages.ldap
+ python39Packages.consul
+ python39Packages.passlib
+ ];
+}
+