aboutsummaryrefslogtreecommitdiff
path: root/node/caribou.nix
diff options
context:
space:
mode:
authorAlex Auvolat <alex@adnab.me>2021-11-18 14:38:48 +0100
committerAlex Auvolat <alex@adnab.me>2021-11-18 14:38:48 +0100
commit478249fbe80c9b64db0f7d4544aa3b50e35c5183 (patch)
treecb58a2954984b02bd1751e809a37c308c973945d /node/caribou.nix
parent45f03096086026a591e8781623e3cff8ed1f51f5 (diff)
downloadnixcfg-478249fbe80c9b64db0f7d4544aa3b50e35c5183.tar.gz
nixcfg-478249fbe80c9b64db0f7d4544aa3b50e35c5183.zip
factor out some configs
Diffstat (limited to 'node/caribou.nix')
-rw-r--r--node/caribou.nix21
1 files changed, 15 insertions, 6 deletions
diff --git a/node/caribou.nix b/node/caribou.nix
index 30b382e..b325739 100644
--- a/node/caribou.nix
+++ b/node/caribou.nix
@@ -3,6 +3,11 @@
{ config, pkgs, ... }:
{
+ # Use the systemd-boot EFI boot loader.
+ boot.loader.systemd-boot.enable = true;
+ boot.loader.timeout = 20;
+ boot.loader.efi.canTouchEfiVariables = true;
+
networking.hostName = "caribou"; # Define your hostname.
networking.interfaces.eno1.useDHCP = false;
@@ -12,12 +17,10 @@
prefixLength = 24;
}
];
- # networking.interfaces.eno1.ipv6.addresses = [
- # {
- # address = "2a01:e0a:c:a720::23";
- # prefixLength = 64;
- # }
- # ];
+ networking.defaultGateway = {
+ address = "192.168.1.254";
+ interface = "eno1";
+ };
networking.wireguard.interfaces.wg0 = {
ips = [ "10.42.0.23/16" ];
@@ -27,6 +30,12 @@
# OR use USB modem plugged in here
#networking.interfaces.enp0s20u1.useDHCP = true;
+
+ # Enable netdata monitoring
+ services.netdata.enable = true;
+
+ # ----
+
# Enable nix-serve
services.nix-serve = {
enable = true;