aboutsummaryrefslogtreecommitdiff
path: root/nix/wgautomesh.nix
diff options
context:
space:
mode:
authorAlex Auvolat <alex@adnab.me>2023-03-20 11:17:38 +0100
committerAlex Auvolat <alex@adnab.me>2023-03-20 11:17:38 +0100
commit6ffaa0ed91a6e2e4ecec6741677ad9307dcdbab2 (patch)
tree9f1767b1b2cd9b5e2a2635429a97cd4cbb0cc914 /nix/wgautomesh.nix
parent90efd9155b4e2014b75133ff123893fb0478c025 (diff)
downloadnixcfg-6ffaa0ed91a6e2e4ecec6741677ad9307dcdbab2.tar.gz
nixcfg-6ffaa0ed91a6e2e4ecec6741677ad9307dcdbab2.zip
use nix enum type
Diffstat (limited to 'nix/wgautomesh.nix')
-rw-r--r--nix/wgautomesh.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nix/wgautomesh.nix b/nix/wgautomesh.nix
index 5a1480c..c64c4af 100644
--- a/nix/wgautomesh.nix
+++ b/nix/wgautomesh.nix
@@ -15,7 +15,7 @@ in
options.services.wgautomesh = {
enable = mkEnableOption "wgautomesh";
logLevel = mkOption {
- type = types.str;
+ type = types.enum [ "trace" "debug" "info" "warn" "error" ];
default = "info";
description = "wgautomesh log level (trace/debug/info/warn/error)";
};