aboutsummaryrefslogtreecommitdiff
path: root/configuration.nix
diff options
context:
space:
mode:
authorAlex Auvolat <alex@adnab.me>2021-11-05 21:44:54 +0100
committerAlex Auvolat <alex@adnab.me>2021-11-05 21:44:54 +0100
commit8637b4729ac3248eb15910a3145d8ef760f59e2f (patch)
treed3ca6cc120bcdd4bf4adfde66c791ef0af75ed7e /configuration.nix
parent681a76e76ab2cfc9149fbbea2467909e3bd0b802 (diff)
downloadnixcfg-8637b4729ac3248eb15910a3145d8ef760f59e2f.tar.gz
nixcfg-8637b4729ac3248eb15910a3145d8ef760f59e2f.zip
Network config
Diffstat (limited to 'configuration.nix')
-rw-r--r--configuration.nix25
1 files changed, 24 insertions, 1 deletions
diff --git a/configuration.nix b/configuration.nix
index 9092f8f..5192986 100644
--- a/configuration.nix
+++ b/configuration.nix
@@ -38,7 +38,7 @@ in
# Route internet traffic via USB modem (=phone) on other computer
networking.nameservers = [ "9.9.9.9" ];
networking.defaultGateway = {
- address = "192.168.1.14";
+ address = "192.168.1.254";
interface = "eno1";
};
@@ -131,12 +131,33 @@ in
# List services that you want to enable:
+ # Enable Yggdrasil networking
+ services.yggdrasil.enable = true;
+ services.yggdrasil.persistentKeys = true;
+ services.yggdrasil.config = {
+ Listen = [
+ "tcp://0.0.0.0:54312"
+ ];
+ Peers = [
+ "tcp://37.187.118.206:53102"
+ "tcp://192.168.1.21:54312"
+ "tcp://192.168.1.22:54312"
+ "tcp://192.168.1.23:54312"
+ ];
+ MulticastInterfaces = [
+ "eno1"
+ ];
+ };
+
# Enable network time
services.ntp.enable = true;
# Enable the OpenSSH daemon.
services.openssh.enable = true;
+ # Enable netdata monitoring
+ services.netdata.enable = true;
+
# Enable Hashicorp Consul & Nomad
services.consul.enable = true;
services.consul.extraConfig =
@@ -193,6 +214,8 @@ in
3900 3901 # Garage (internal RPC traffic)
4646 4647 4648 # Nomad
8500 8300 8301 8302 # Consul
+ 19999 # Netdata
+ 54312 # Yggdrasil
];
networking.firewall.allowedUDPPorts = [
4648 # Nomad