aboutsummaryrefslogtreecommitdiff
path: root/configuration.nix
diff options
context:
space:
mode:
authorAlex Auvolat <alex@adnab.me>2022-02-27 14:18:43 +0100
committerAlex Auvolat <alex@adnab.me>2022-02-27 14:18:43 +0100
commit02ed668286cebfa3ac079ab5263950a22816f61c (patch)
tree10d132a483e789c2a24c37fc9bed63e1ec63f340 /configuration.nix
parent7d486b3907cdd902d38d799eba9651966f0e7c4f (diff)
downloadnixcfg-02ed668286cebfa3ac079ab5263950a22816f61c.tar.gz
nixcfg-02ed668286cebfa3ac079ab5263950a22816f61c.zip
Remove mount garage using rclone systemd service
Diffstat (limited to 'configuration.nix')
-rw-r--r--configuration.nix22
1 files changed, 4 insertions, 18 deletions
diff --git a/configuration.nix b/configuration.nix
index 4e323eb..7e32a8d 100644
--- a/configuration.nix
+++ b/configuration.nix
@@ -38,6 +38,10 @@
"vm.max_map_count" = 262144;
};
+ services.journald.extraConfig = ''
+SystemMaxUse=1G
+ '';
+
# List packages installed in system profile. To search, run:
# $ nix search wget
environment.systemPackages = with pkgs; [
@@ -72,24 +76,6 @@
# ---- CONFIG FOR DEUXFLEURS CLUSTER ----
- # Mount Garage using Rclone
- systemd.services.mountgarage = {
- enable = false;
- description = "Mount the Garage data store";
- path = [
- pkgs.fuse
- pkgs.rclone
- ];
- unitConfig = {
- Type = "simple";
- };
- serviceConfig = {
- ExecStartPre = "${pkgs.bash}/bin/sh -c \"mkdir -p /mnt/garage-staging; fusermount -u /mnt/garage-staging || exit 0\"";
- ExecStart = "${pkgs.rclone}/bin/rclone --config /root/rclone.conf mount --vfs-cache-mode full --vfs-cache-max-size 1G --cache-dir /root/mountgarage-cache staging: /mnt/garage-staging";
- };
- wantedBy = [ "multi-user.target" ];
- };
-
# Open ports in the firewall.
networking.firewall = {
enable = true;