aboutsummaryrefslogtreecommitdiff
path: root/cluster/prod/app/cryptpad/build/deuxfleurs.nix
diff options
context:
space:
mode:
authoradrien <adrien@luxeylab.net>2024-04-18 17:35:36 +0000
committeradrien <adrien@luxeylab.net>2024-04-18 17:35:36 +0000
commit18e73b18f39ea19bae54fb4fae461e6c141b49ce (patch)
tree22bba1330f1e58716bba0812d831dec1c69d62c9 /cluster/prod/app/cryptpad/build/deuxfleurs.nix
parent718a23b74bd13d09306bb17877ceec19464eed27 (diff)
parent9111997f845cb61bcbe5b5f49672ba26814d19c9 (diff)
downloadnixcfg-18e73b18f39ea19bae54fb4fae461e6c141b49ce.tar.gz
nixcfg-18e73b18f39ea19bae54fb4fae461e6c141b49ce.zip
Merge pull request 'cluster/prod(app): Upgrade CryptPad to 2024.3.0' (#23) from KokaKiwi/nixcfg:crytptpad-upgrade-1 into main
Reviewed-on: https://git.deuxfleurs.fr/Deuxfleurs/nixcfg/pulls/23
Diffstat (limited to 'cluster/prod/app/cryptpad/build/deuxfleurs.nix')
-rw-r--r--cluster/prod/app/cryptpad/build/deuxfleurs.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/cluster/prod/app/cryptpad/build/deuxfleurs.nix b/cluster/prod/app/cryptpad/build/deuxfleurs.nix
new file mode 100644
index 0000000..5cb8b8e
--- /dev/null
+++ b/cluster/prod/app/cryptpad/build/deuxfleurs.nix
@@ -0,0 +1,12 @@
+{ name ? "deuxfleurs/cryptpad"
+, tag ? "nix-latest"
+}: let
+ sources = import ./nix/sources.nix;
+ pkgs = import sources.nixpkgs {};
+in rec {
+ cryptpad = pkgs.callPackage ./default.nix {};
+ docker = pkgs.callPackage ./docker.nix {
+ inherit name tag;
+ inherit cryptpad;
+ };
+}