aboutsummaryrefslogtreecommitdiff
path: root/cluster/prod/app/cryptpad/build/common.nix
diff options
context:
space:
mode:
authorAlex Auvolat <alex@adnab.me>2022-08-24 15:42:47 +0200
committerAlex Auvolat <alex@adnab.me>2022-08-24 15:42:47 +0200
commit2e8923b383eb06c53261eee8e5c442b857fb67e4 (patch)
tree0ad148f75f7b54dfed2dbac8f43f6df9badc502a /cluster/prod/app/cryptpad/build/common.nix
parent9848f3090f77363a2fda0f9fa673ebcf1fb8228c (diff)
downloadnixcfg-2e8923b383eb06c53261eee8e5c442b857fb67e4.tar.gz
nixcfg-2e8923b383eb06c53261eee8e5c442b857fb67e4.zip
Move app files into cluster subdirectories; add prod garage
Diffstat (limited to 'cluster/prod/app/cryptpad/build/common.nix')
-rw-r--r--cluster/prod/app/cryptpad/build/common.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/cluster/prod/app/cryptpad/build/common.nix b/cluster/prod/app/cryptpad/build/common.nix
new file mode 100644
index 0000000..957d381
--- /dev/null
+++ b/cluster/prod/app/cryptpad/build/common.nix
@@ -0,0 +1,22 @@
+rec {
+ cryptpadVersion = "4.14.1+2";
+ cryptpadCommit = "18c371bb5bda068a5d962dd7c4f0726320eea5e9";
+
+ pkgsSrc = fetchTarball {
+ # Latest commit on https://github.com/NixOS/nixpkgs/tree/nixos-21.11
+ # As of 2022-04-15
+ url ="https://github.com/NixOS/nixpkgs/archive/2f06b87f64bc06229e05045853e0876666e1b023.tar.gz";
+ sha256 = "sha256:1d7zg96xw4qsqh7c89pgha9wkq3rbi9as3k3d88jlxy2z0ns0cy2";
+ };
+ cryptpadSrc = builtins.fetchGit {
+ url = "https://github.com/superboum/cryptpad";
+ ref = "refs/tags/${cryptpadVersion}";
+ rev = cryptpadCommit;
+ };
+ bower2nixSrc = builtins.fetchGit {
+ url = "https://github.com/superboum/bower2nix";
+ ref = "new";
+ rev = "618ab3e206325c63fe4526ae842a1f6c792b0e27";
+ };
+ nodejs = "nodejs-slim-16_x";
+}