aboutsummaryrefslogtreecommitdiff
path: root/app/shell.nix
diff options
context:
space:
mode:
authorQuentin Dufour <quentin@deuxfleurs.fr>2022-05-10 15:58:09 +0200
committerQuentin Dufour <quentin@deuxfleurs.fr>2022-05-10 15:58:09 +0200
commit52f14f9da2236caf999094d666f3fdb9211bdff0 (patch)
tree018455c2150e2b1bbb3709dd2a8b7be23364457a /app/shell.nix
parent8cd2f72926293a8bca1b42fe7bccb2b9e61740d1 (diff)
downloadnixcfg-52f14f9da2236caf999094d666f3fdb9211bdff0.tar.gz
nixcfg-52f14f9da2236caf999094d666f3fdb9211bdff0.zip
Backup Cryptpad
Diffstat (limited to 'app/shell.nix')
-rw-r--r--app/shell.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/app/shell.nix b/app/shell.nix
new file mode 100644
index 0000000..c9b8053
--- /dev/null
+++ b/app/shell.nix
@@ -0,0 +1,15 @@
+{
+ pkgs ? import <nixpkgs> {}
+}:
+
+with pkgs; mkShell {
+ nativeBuildInputs = [
+ nomad
+ docker-compose
+ python39Packages.pip
+ python39Packages.ldap
+ python39Packages.consul
+ python39Packages.passlib
+ ];
+}
+