aboutsummaryrefslogtreecommitdiff
path: root/app/cryptpad/build/nix.lock/npm.nix
diff options
context:
space:
mode:
authorQuentin Dufour <quentin@deuxfleurs.fr>2022-05-06 17:34:30 +0200
committerQuentin Dufour <quentin@deuxfleurs.fr>2022-05-06 17:35:09 +0200
commit071e87a2025edfa8694fd3ae05be894d2be434ee (patch)
treecacc8e997f669a3ae497b2256394aa90c83c711e /app/cryptpad/build/nix.lock/npm.nix
parent0561fa8d5f07f183a27b068feb820e4777b0c020 (diff)
downloadnixcfg-071e87a2025edfa8694fd3ae05be894d2be434ee.tar.gz
nixcfg-071e87a2025edfa8694fd3ae05be894d2be434ee.zip
Own packaging of Cryptpad
Diffstat (limited to 'app/cryptpad/build/nix.lock/npm.nix')
-rw-r--r--app/cryptpad/build/nix.lock/npm.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/app/cryptpad/build/nix.lock/npm.nix b/app/cryptpad/build/nix.lock/npm.nix
new file mode 100644
index 0000000..53bdef1
--- /dev/null
+++ b/app/cryptpad/build/nix.lock/npm.nix
@@ -0,0 +1,17 @@
+# This file has been generated by node2nix 1.9.0. Do not edit!
+
+{pkgs ? import <nixpkgs> {
+ inherit system;
+ }, system ? builtins.currentSystem, nodejs ? pkgs."nodejs-12_x"}:
+
+let
+ nodeEnv = import ./node-env.nix {
+ inherit (pkgs) stdenv lib python2 runCommand writeTextFile writeShellScript;
+ inherit pkgs nodejs;
+ libtool = if pkgs.stdenv.isDarwin then pkgs.darwin.cctools else null;
+ };
+in
+import ./node-packages.nix {
+ inherit (pkgs) fetchurl nix-gitignore stdenv lib fetchgit;
+ inherit nodeEnv;
+}