diff options
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 13 |
1 files changed, 10 insertions, 3 deletions
@@ -3,8 +3,16 @@ name = "netapp" version = "0.1.0" authors = ["Alex Auvolat <alex@adnab.me>"] edition = "2018" +license-file = "LICENSE" +description = "A toolkit library for distributed software" +homepage = "https://git.deuxfleurs.fr/lx/netapp" +repository = "https://git.deuxfleurs.fr/lx/netapp" +readme = "README.md" +keywords = ["protocol", "rpc", "mesh", "distributed"] +categories = ["asynchronous", "network-programming"] -# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html +[lib] +name = "netapp" [dependencies] async-std = { version = "1.5.0", default-features = false } @@ -28,6 +36,5 @@ bytes = "0.6.0" lru = "0.6" sodiumoxide = { version = "0.2.5-0", package = "kuska-sodiumoxide" } -kuska-handshake = { version = "0.1.1", path = "../handshake", features = ["default", "tokio_compat"] } -#kuska-handshake = { version = "0.1.1", git = "https://github.com/kuska-ssb/handshake", branch = "master", features = ["default", "tokio_compat"] } +kuska-handshake = { version = "0.1.2", features = ["default", "tokio_compat"] } |