aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorAlex Auvolat <alex@adnab.me>2022-02-18 20:10:46 +0100
committerAlex Auvolat <alex@adnab.me>2022-02-18 20:10:46 +0100
commitfb6b4dc9a95f4268775e674323a2b84c7b4ae7f0 (patch)
tree9ea5762b36d81c87bf0abdad1113cebf3d75a4c4 /Cargo.toml
parentab0f7785ae73e2f5aaf912fc3c0f2cd724967546 (diff)
downloadnetapp-fb6b4dc9a95f4268775e674323a2b84c7b4ae7f0.tar.gz
netapp-fb6b4dc9a95f4268775e674323a2b84c7b4ae7f0.zip
Correct implementation of distributed tracing
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml5
1 files changed, 3 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 4b6db48..8eb32db 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,6 +1,6 @@
[package]
name = "netapp"
-version = "0.3.2"
+version = "0.4.0"
authors = ["Alex Auvolat <alex@adnab.me>"]
edition = "2018"
license-file = "LICENSE"
@@ -17,7 +17,7 @@ name = "netapp"
[features]
default = []
basalt = ["lru", "rand"]
-telemetry = ["opentelemetry", "rand"]
+telemetry = ["opentelemetry", "opentelemetry-contrib", "rand"]
[dependencies]
futures = "0.3.17"
@@ -43,6 +43,7 @@ sodiumoxide = { version = "0.2.5-0", package = "kuska-sodiumoxide" }
kuska-handshake = { version = "0.2.0", features = ["default", "async_std"] }
opentelemetry = { version = "0.17", optional = true }
+opentelemetry-contrib = { version = "0.9", optional = true }
[dev-dependencies]
env_logger = "0.8"