aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorAlex Auvolat <alex@adnab.me>2021-03-10 22:32:14 +0100
committerAlex Auvolat <alex@adnab.me>2021-03-10 22:32:14 +0100
commitc05600d749b2ef56d40bed7e41a6a94e02046fb6 (patch)
tree84b5cde646f884b8390655d5ba09d2646e9d4ef2 /Cargo.toml
parenta2e2f5e96bd8c77bb309f881691ebec090993634 (diff)
downloadnetapp-c05600d749b2ef56d40bed7e41a6a94e02046fb6.tar.gz
netapp-c05600d749b2ef56d40bed7e41a6a94e02046fb6.zip
make basalt optionnal during compilation
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml10
1 files changed, 8 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 166c790..05634b3 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -14,6 +14,10 @@ categories = ["asynchronous", "network-programming"]
[lib]
name = "netapp"
+[features]
+default = []
+basalt = ["lru", "rand"]
+
[dependencies]
async-std = { version = "1.5.0", default-features = false }
tokio = { version = "0.2", default-features = false, features = ["net", "tcp", "rt-core", "rt-threaded", "sync", "time", "macros"] }
@@ -24,7 +28,7 @@ hex = "0.4.2"
base64 = "0.12.1"
structopt = { version = "0.3", default-features = false }
-rand = "0.5.5"
+rand = { version = "0.5.5", optional = true }
chrono = "0.4"
log = "0.4.8"
@@ -33,8 +37,10 @@ arc-swap = "1.1"
async-trait = "0.1.7"
err-derive = "0.2.3"
bytes = "0.6.0"
-lru = "0.6"
+lru = { version = "0.6", optional = true }
sodiumoxide = { version = "0.2.5-0", package = "kuska-sodiumoxide" }
kuska-handshake = { version = "0.1.2", features = ["default", "tokio_compat"] }
+[package.metadata.cargo-all-features]
+skip_optional_dependencies = true