diff options
author | Alex Auvolat <alex@adnab.me> | 2020-12-12 19:08:57 +0100 |
---|---|---|
committer | Alex Auvolat <alex@adnab.me> | 2020-12-12 19:08:57 +0100 |
commit | 54c7c50bb57450f4fbb62eb5e6258bc34f37a99d (patch) | |
tree | 59b3afe4303900ca5c86b1ae1c114b900134f729 /Cargo.toml | |
parent | dbb15807b927c27df53bb4a6964c268a140635b3 (diff) | |
download | netapp-54c7c50bb57450f4fbb62eb5e6258bc34f37a99d.tar.gz netapp-54c7c50bb57450f4fbb62eb5e6258bc34f37a99d.zip |
Useless dependencies get removed
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 14 |
1 files changed, 7 insertions, 7 deletions
@@ -1,16 +1,16 @@ [package] name = "netapp" version = "0.1.0" -authors = ["Alex Auvolat <alex.auvolat@inria.fr>"] +authors = ["Alex Auvolat <alex@adnab.me>"] edition = "2018" # See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html [dependencies] -async-std = { version = "1.5.0", features=["unstable","attributes"] } -tokio = { version = "0.2", features = ["full"] } +async-std = { version = "1.5.0", default-features = false } +tokio = { version = "0.2", default-features = false, features = ["net", "tcp", "rt-core", "rt-threaded", "sync", "time", "macros"] } -serde = { version = "1.0", default-features = false, features = ["derive", "rc"] } +serde = { version = "1.0", default-features = false, features = ["derive"] } rmp-serde = "0.14.3" hex = "0.4.2" base64 = "0.12.1" @@ -27,7 +27,7 @@ err-derive = "0.2.3" bytes = "0.6.0" lru = "0.6" -sodiumoxide = { git = "https://github.com/Dhole/sodiumoxidez", branch = "extra" } -kuska-handshake = { path = "../handshake", features = ["default", "tokio_compat"] } -#kuska-handshake = { git = "https://github.com/kuska-ssb/handshake", branch = "master", features = ["default", "tokio_compat"] } +sodiumoxide = { version = "0.2.5-0", package = "kuska-sodiumoxide" } +kuska-handshake = { version = "0.1.1", path = "../handshake", features = ["default", "tokio_compat"] } +#kuska-handshake = { version = "0.1.1", git = "https://github.com/kuska-ssb/handshake", branch = "master", features = ["default", "tokio_compat"] } |