diff options
author | trinity-1686a <trinity@deuxfleurs.fr> | 2022-06-05 15:33:43 +0200 |
---|---|---|
committer | trinity-1686a <trinity@deuxfleurs.fr> | 2022-06-05 15:33:43 +0200 |
commit | 368ba908794901bc793c6a087c02241be046bdf2 (patch) | |
tree | 389910f1e1476c9531a01d2e53060e1056cca266 /Cargo.toml | |
parent | 648e015e3a73b96973343e0a1f861c9ea41cc24d (diff) | |
download | netapp-368ba908794901bc793c6a087c02241be046bdf2.tar.gz netapp-368ba908794901bc793c6a087c02241be046bdf2.zip |
initial work on associated stream
still require testing, and fixing a few kinks:
- sending packets > 16k truncate them
- send one more packet than it could at eos
- probably update documentation
/!\ contains breaking changes
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 2 |
1 files changed, 2 insertions, 0 deletions
@@ -21,6 +21,7 @@ telemetry = ["opentelemetry", "opentelemetry-contrib", "rand"] [dependencies] futures = "0.3.17" +pin-project = "1.0.10" tokio = { version = "1.0", default-features = false, features = ["net", "rt", "rt-multi-thread", "sync", "time", "macros", "io-util", "signal"] } tokio-util = { version = "0.6.8", default-features = false, features = ["compat"] } tokio-stream = "0.1.7" @@ -47,6 +48,7 @@ opentelemetry-contrib = { version = "0.9", optional = true } [dev-dependencies] env_logger = "0.8" +pretty_env_logger = "0.4" structopt = { version = "0.3", default-features = false } chrono = "0.4" |