aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorAlex Auvolat <alex@adnab.me>2020-12-14 11:35:41 +0100
committerAlex Auvolat <alex@adnab.me>2020-12-14 11:35:41 +0100
commitc81fd742c4dc1b6b924125fac6f270e2a2596310 (patch)
tree05eae48df7fe01091634a96ba4eabdd1d031f1f9 /Cargo.toml
parente761f2f6efe6ce3fd6080eac85de511a3073959b (diff)
downloadnetapp-c81fd742c4dc1b6b924125fac6f270e2a2596310.tar.gz
netapp-c81fd742c4dc1b6b924125fac6f270e2a2596310.zip
Prepare Cargo.toml for publication
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml13
1 files changed, 10 insertions, 3 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 3d0cd1b..96539b3 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -3,8 +3,16 @@ name = "netapp"
version = "0.1.0"
authors = ["Alex Auvolat <alex@adnab.me>"]
edition = "2018"
+license-file = "LICENSE"
+description = "A toolkit library for distributed software"
+homepage = "https://git.deuxfleurs.fr/lx/netapp"
+repository = "https://git.deuxfleurs.fr/lx/netapp"
+readme = "README.md"
+keywords = ["protocol", "rpc", "mesh", "distributed"]
+categories = ["asynchronous", "network-programming"]
-# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+[lib]
+name = "netapp"
[dependencies]
async-std = { version = "1.5.0", default-features = false }
@@ -28,6 +36,5 @@ bytes = "0.6.0"
lru = "0.6"
sodiumoxide = { version = "0.2.5-0", package = "kuska-sodiumoxide" }
-kuska-handshake = { version = "0.1.1", path = "../handshake", features = ["default", "tokio_compat"] }
-#kuska-handshake = { version = "0.1.1", git = "https://github.com/kuska-ssb/handshake", branch = "master", features = ["default", "tokio_compat"] }
+kuska-handshake = { version = "0.1.2", features = ["default", "tokio_compat"] }